aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorRani Hod <rani.hod@gmail.com>2023-10-08 18:18:13 +0300
committerHauke Mehrtens <hauke@hauke-m.de>2023-10-31 00:44:03 +0100
commit07e9c27bde133e7e05c691d71b9b1da0554cb5f2 (patch)
treefa9bffa6aedf68b849293862654731520b120ea5 /package
parent3d0a78add22754aa891529b6702b5e4c7b837446 (diff)
downloadupstream-07e9c27bde133e7e05c691d71b9b1da0554cb5f2.tar.gz
upstream-07e9c27bde133e7e05c691d71b9b1da0554cb5f2.tar.bz2
upstream-07e9c27bde133e7e05c691d71b9b1da0554cb5f2.zip
build: hide kmod-zram config unless enabled
Currently the zram default compressor choice is displayed whether or not zram is activated. Since the default choice is lzo-rle, this adds a false dependency on kmod-lib-lzo. With this patch, the choice options appear only when activating zram. Signed-off-by: Rani Hod <rani.hod@gmail.com> (cherry picked from commit 62ada26de28e6c43a957b8f186ead1f45e6a5623)
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/other.mk20
1 files changed, 11 insertions, 9 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index cd827725bd..9c10b97501 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -1013,31 +1013,33 @@ define KernelPackage/zram/description
endef
define KernelPackage/zram/config
- choice
- prompt "ZRAM Default compressor"
- default ZRAM_DEF_COMP_LZORLE
+ if PACKAGE_kmod-zram
+ choice
+ prompt "ZRAM Default compressor"
+ default ZRAM_DEF_COMP_LZORLE
- config ZRAM_DEF_COMP_LZORLE
+ config ZRAM_DEF_COMP_LZORLE
bool "lzo-rle"
select PACKAGE_kmod-lib-lzo
- config ZRAM_DEF_COMP_LZO
+ config ZRAM_DEF_COMP_LZO
bool "lzo"
select PACKAGE_kmod-lib-lzo
- config ZRAM_DEF_COMP_LZ4
+ config ZRAM_DEF_COMP_LZ4
bool "lz4"
select PACKAGE_kmod-lib-lz4
- config ZRAM_DEF_COMP_LZ4HC
+ config ZRAM_DEF_COMP_LZ4HC
bool "lz4-hc"
select PACKAGE_kmod-lib-lz4hc
- config ZRAM_DEF_COMP_ZSTD
+ config ZRAM_DEF_COMP_ZSTD
bool "zstd"
select PACKAGE_kmod-lib-zstd
- endchoice
+ endchoice
+ endif
endef
$(eval $(call KernelPackage,zram))