aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorAlexandru Gagniuc <mr.nuke.me@gmail.com>2022-07-19 20:27:49 -0500
committerSander Vanheule <sander@svanheule.net>2022-08-13 19:59:47 +0200
commitb664646db74a7c4c541c7fa835d7689dd897dcca (patch)
tree13d163179a57f9a2cc23f83024f8c2f3df9ac5f8 /package
parentc5fbd49d3fa6cdb10c635c74db91ca61177f9b70 (diff)
downloadupstream-b664646db74a7c4c541c7fa835d7689dd897dcca.tar.gz
upstream-b664646db74a7c4c541c7fa835d7689dd897dcca.tar.bz2
upstream-b664646db74a7c4c541c7fa835d7689dd897dcca.zip
kernel: add kmod-hwmon-tps23861 support
Package the tps23861.ko module, which supports Texas Instruments TPS23861 PoE+ controller. Signed-off-by: Alexandru Gagniuc <mr.nuke.me@gmail.com>
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/hwmon.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/hwmon.mk b/package/kernel/linux/modules/hwmon.mk
index b75c741ba0..42df3a94f7 100644
--- a/package/kernel/linux/modules/hwmon.mk
+++ b/package/kernel/linux/modules/hwmon.mk
@@ -519,6 +519,20 @@ endef
$(eval $(call KernelPackage,hwmon-tmp421))
+define KernelPackage/hwmon-tps23861
+ TITLE:=Texas Instruments TPS23861 PoE PSE
+ KCONFIG:=CONFIG_SENSORS_TPS23861
+ FILES:=$(LINUX_DIR)/drivers/hwmon/tps23861.ko
+ AUTOLOAD:=$(call AutoProbe,tps23861)
+ $(call AddDepends/hwmon,+kmod-i2c-core)
+endef
+
+define KernelPackage/hwmon-tps23861/description
+ Kernel module for the Texas Instruments TPS23861 802.3at PoE PSE chips.
+endef
+
+$(eval $(call KernelPackage,hwmon-tps23861))
+
define KernelPackage/hwmon-vid
TITLE:=VID/VRM/VRD voltage conversion module.
KCONFIG:=CONFIG_HWMON_VID