aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorLuiz Angelo Daros de Luca <luizluca@gmail.com>2022-04-26 19:28:34 -0300
committerChristian Marangi <ansuelsmth@gmail.com>2022-07-01 20:22:52 +0200
commit96d056f5f0894f492e5a4102d954d54ea7a741d0 (patch)
treeaf5fe90c213ba42c9c9d52d261d441dba6b7c8b0 /package
parent575ec7a4b1a085f243961ef13dd23f228a60e67e (diff)
downloadupstream-96d056f5f0894f492e5a4102d954d54ea7a741d0.tar.gz
upstream-96d056f5f0894f492e5a4102d954d54ea7a741d0.tar.bz2
upstream-96d056f5f0894f492e5a4102d954d54ea7a741d0.zip
kernel: netdevices: add rtl8367 module
Create a package for rtl8367 to use it as loadable module instead of a builtin one. Signed-off-by: Luiz Angelo Daros de Luca <luizluca@gmail.com>
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/netdevices.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/netdevices.mk b/package/kernel/linux/modules/netdevices.mk
index 7b8e808e6d..cc15885148 100644
--- a/package/kernel/linux/modules/netdevices.mk
+++ b/package/kernel/linux/modules/netdevices.mk
@@ -399,6 +399,22 @@ endef
$(eval $(call KernelPackage,switch-rtl8366s))
+define KernelPackage/switch-rtl8367
+ SUBMENU:=$(NETWORK_DEVICES_MENU)
+ TITLE:=Realtek RTL8367 switch support
+ DEPENDS:=+kmod-switch-rtl8366-smi
+ KCONFIG:=CONFIG_RTL8367_PHY
+ FILES:=$(LINUX_DIR)/drivers/net/phy/rtl8367.ko
+ AUTOLOAD:=$(call AutoLoad,43,rtl8367,1)
+endef
+
+define KernelPackage/switch-rtl8367/description
+ Realtek RTL8367 switch support
+endef
+
+$(eval $(call KernelPackage,switch-rtl8367))
+
+
define KernelPackage/switch-rtl8367b
SUBMENU:=$(NETWORK_DEVICES_MENU)
TITLE:=Realtek RTL8367R/B switch support