aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-10-02 19:03:32 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-10-02 21:26:12 +0200
commit53d19bb8cf88483df4fe4557c90cb3d85d9dd086 (patch)
tree511dfb42877fe8c241024e83a1fb191061dca36b /package
parent3810e897295cb66bc45a62bc2c0b70a01004fe3b (diff)
downloadupstream-53d19bb8cf88483df4fe4557c90cb3d85d9dd086.tar.gz
upstream-53d19bb8cf88483df4fe4557c90cb3d85d9dd086.tar.bz2
upstream-53d19bb8cf88483df4fe4557c90cb3d85d9dd086.zip
treewide: use AUTORELEASE on all uboot-* packages
Nobody ever updates PKG_RELEASE when changing devices or setup in the various uboot-* packages. Use $(AUTORELEASE) so we still have proper versioning there. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'package')
-rw-r--r--package/boot/uboot-at91/Makefile2
-rw-r--r--package/boot/uboot-fritz4040/Makefile2
-rw-r--r--package/boot/uboot-imx6/Makefile2
-rw-r--r--package/boot/uboot-lantiq/Makefile2
-rw-r--r--package/boot/uboot-mxs/Makefile2
-rw-r--r--package/boot/uboot-omap/Makefile2
-rw-r--r--package/boot/uboot-oxnas/Makefile2
-rw-r--r--package/boot/uboot-ramips/Makefile2
-rw-r--r--package/boot/uboot-rockchip/Makefile2
-rw-r--r--package/boot/uboot-tegra/Makefile2
10 files changed, 10 insertions, 10 deletions
diff --git a/package/boot/uboot-at91/Makefile b/package/boot/uboot-at91/Makefile
index a8a71239a3..06cfcd9045 100644
--- a/package/boot/uboot-at91/Makefile
+++ b/package/boot/uboot-at91/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_VERSION:=linux4sam-2020.04
-PKG_RELEASE:=2
+PKG_RELEASE:=$(AUTORELEASE)
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://github.com/linux4sam/u-boot-at91.git
diff --git a/package/boot/uboot-fritz4040/Makefile b/package/boot/uboot-fritz4040/Makefile
index 2130581765..d7cde938ce 100644
--- a/package/boot/uboot-fritz4040/Makefile
+++ b/package/boot/uboot-fritz4040/Makefile
@@ -14,7 +14,7 @@ PKG_SOURCE_VERSION:=f92be9d783b1210c020d5d6129e210a94bb7e290
PKG_SOURCE_DATE:=2019-10-19
PKG_MIRROR_HASH:=e40a7f624b1758b276f81c765ef1da568c595b8bd54568b9cceca7d170ebc612
-PKG_RELEASE:=1
+PKG_RELEASE:=$(AUTORELEASE)
include $(INCLUDE_DIR)/u-boot.mk
include $(INCLUDE_DIR)/package.mk
diff --git a/package/boot/uboot-imx6/Makefile b/package/boot/uboot-imx6/Makefile
index ed6074053a..6c2297dd81 100644
--- a/package/boot/uboot-imx6/Makefile
+++ b/package/boot/uboot-imx6/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_VERSION:=2020.04
-PKG_RELEASE:=1
+PKG_RELEASE:=$(AUTORELEASE)
PKG_HASH:=fe732aaf037d9cc3c0909bad8362af366ae964bbdac6913a34081ff4ad565372
diff --git a/package/boot/uboot-lantiq/Makefile b/package/boot/uboot-lantiq/Makefile
index 55038fdf65..2786f1afda 100644
--- a/package/boot/uboot-lantiq/Makefile
+++ b/package/boot/uboot-lantiq/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=u-boot
PKG_VERSION:=2013.10
-PKG_RELEASE:=1
+PKG_RELEASE:=$(AUTORELEASE)
PKG_HASH:=0d71e62beb952b41ebafb20a7ee4df2f960db64c31b054721ceb79ff14014c55
diff --git a/package/boot/uboot-mxs/Makefile b/package/boot/uboot-mxs/Makefile
index 2a202dca8f..f4211d3a54 100644
--- a/package/boot/uboot-mxs/Makefile
+++ b/package/boot/uboot-mxs/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_VERSION:=2020.04
-PKG_RELEASE:=1
+PKG_RELEASE:=$(AUTORELEASE)
PKG_HASH:=fe732aaf037d9cc3c0909bad8362af366ae964bbdac6913a34081ff4ad565372
diff --git a/package/boot/uboot-omap/Makefile b/package/boot/uboot-omap/Makefile
index f66b8d5331..d0158a7284 100644
--- a/package/boot/uboot-omap/Makefile
+++ b/package/boot/uboot-omap/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_VERSION:=2020.04
-PKG_RELEASE:=1
+PKG_RELEASE:=$(AUTORELEASE)
PKG_HASH:=fe732aaf037d9cc3c0909bad8362af366ae964bbdac6913a34081ff4ad565372
diff --git a/package/boot/uboot-oxnas/Makefile b/package/boot/uboot-oxnas/Makefile
index daa266ea8c..98c6cee8e1 100644
--- a/package/boot/uboot-oxnas/Makefile
+++ b/package/boot/uboot-oxnas/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_VERSION:=2014.10
-PKG_RELEASE:=1
+PKG_RELEASE:=$(AUTORELEASE)
PKG_HASH:=d3b132a7a9b3f3182b7aad71c2dfbd4fc15bea83e12c76134eb3ffefc07d1c71
diff --git a/package/boot/uboot-ramips/Makefile b/package/boot/uboot-ramips/Makefile
index 5229f5cd3c..337ea00479 100644
--- a/package/boot/uboot-ramips/Makefile
+++ b/package/boot/uboot-ramips/Makefile
@@ -4,7 +4,7 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_VERSION:=2020.04
-PKG_RELEASE:=1
+PKG_RELEASE:=$(AUTORELEASE)
PKG_HASH:=fe732aaf037d9cc3c0909bad8362af366ae964bbdac6913a34081ff4ad565372
diff --git a/package/boot/uboot-rockchip/Makefile b/package/boot/uboot-rockchip/Makefile
index ff246b5771..f419ec6ca7 100644
--- a/package/boot/uboot-rockchip/Makefile
+++ b/package/boot/uboot-rockchip/Makefile
@@ -6,7 +6,7 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_VERSION:=2021.07
-PKG_RELEASE:=1
+PKG_RELEASE:=$(AUTORELEASE)
PKG_HASH:=312b7eeae44581d1362c3a3f02c28d806647756c82ba8c72241c7cdbe68ba77e
diff --git a/package/boot/uboot-tegra/Makefile b/package/boot/uboot-tegra/Makefile
index a3d66900db..582f7be947 100644
--- a/package/boot/uboot-tegra/Makefile
+++ b/package/boot/uboot-tegra/Makefile
@@ -7,7 +7,7 @@
include $(TOPDIR)/rules.mk
PKG_VERSION := 2020.04
-PKG_RELEASE := 1
+PKG_RELEASE:=$(AUTORELEASE)
PKG_HASH := fe732aaf037d9cc3c0909bad8362af366ae964bbdac6913a34081ff4ad565372