aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorStijn Tintel <stijn@linux-ipv6.be>2022-06-20 19:23:18 +0300
committerStijn Tintel <stijn@linux-ipv6.be>2022-06-28 03:23:50 +0300
commit48c321082c25f8312d3839e1df6d30822dc13fae (patch)
tree54f129a7cb02bd36d5987a21dd26b93d978bbe90 /package
parent7bf73e270e7f1704b21860712820dcf12b593e91 (diff)
downloadupstream-48c321082c25f8312d3839e1df6d30822dc13fae.tar.gz
upstream-48c321082c25f8312d3839e1df6d30822dc13fae.tar.bz2
upstream-48c321082c25f8312d3839e1df6d30822dc13fae.zip
hostapd: add config symbol to enable MBO
Multi Band Operation aka Agile Multiband introduces new Transition and Transition Rejection Reason Codes that should improve client steering. Add a config symbol to enable it, and enable it by default for the full variants. Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be> Acked-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'package')
-rw-r--r--package/network/services/hostapd/Config.in14
-rw-r--r--package/network/services/hostapd/Makefile1
2 files changed, 15 insertions, 0 deletions
diff --git a/package/network/services/hostapd/Config.in b/package/network/services/hostapd/Config.in
index 5c00f3e24e..e22bbff83a 100644
--- a/package/network/services/hostapd/Config.in
+++ b/package/network/services/hostapd/Config.in
@@ -87,3 +87,17 @@ config WPA_ENABLE_WEP
for anything anymore. The functionality needed to use WEP is available in the
current hostapd release under this optional build parameter and completely
removed in a future release.
+
+config WPA_MBO_SUPPORT
+ bool "Multi Band Operation (Agile Multiband)"
+ default PACKAGE_wpa-supplicant || \
+ PACKAGE_wpa-supplicant-openssl || \
+ PACKAGE_wpa-supplicant-wolfssl || \
+ PACKAGE_wpad || \
+ PACKAGE_wpad-openssl || \
+ PACKAGE_wpad-wolfssl
+ help
+ Multi Band Operation aka (Agile Multiband) enables features
+ that facilitate efficient use of multiple frequency bands.
+ Enabling MBO on an AP using RSN requires 802.11w to be enabled.
+ Hostapd will refuse to start if MBO and RSN are enabled without 11w.
diff --git a/package/network/services/hostapd/Makefile b/package/network/services/hostapd/Makefile
index a3274c8d4d..c69d2a826b 100644
--- a/package/network/services/hostapd/Makefile
+++ b/package/network/services/hostapd/Makefile
@@ -91,6 +91,7 @@ DRIVER_MAKEOPTS= \
CONFIG_IEEE80211AC=$(HOSTAPD_IEEE80211AC) \
CONFIG_IEEE80211AX=$(HOSTAPD_IEEE80211AX) \
CONFIG_DRIVER_WEXT=$(CONFIG_DRIVER_WEXT_SUPPORT) \
+ CONFIG_MBO=$(CONFIG_WPA_MBO_SUPPORT)
ifeq ($(SSL_VARIANT),openssl)
DRIVER_MAKEOPTS += CONFIG_TLS=openssl CONFIG_SAE=y