aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorTony Butler <spudz76@gmail.com>2022-11-27 19:14:48 -0800
committerTony Butler <spudz76@gmail.com>2022-12-11 09:32:53 -0800
commit1e240f60a501874bccd3602de571c0a46f50cc7d (patch)
tree7f225fb8bf2053577250957ab02fdc65c6b6a366 /package
parent9a1ab8aa0398f93360bf54d81bcd332cd413c03f (diff)
downloadupstream-1e240f60a501874bccd3602de571c0a46f50cc7d.tar.gz
upstream-1e240f60a501874bccd3602de571c0a46f50cc7d.tar.bz2
upstream-1e240f60a501874bccd3602de571c0a46f50cc7d.zip
kernel: modules/lib-lz4: add lz4hc_compress
enable option `CONFIG_CRYPTO_LZ4HC` to match default kernel config this only adds the `lz4hc_compress` module, and has no effect on the `lz4_decompress` module which already supports any flavor Signed-off-by: Tony Butler <spudz76@gmail.com>
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/lib.mk4
-rw-r--r--package/kernel/linux/modules/other.mk4
2 files changed, 7 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/lib.mk b/package/kernel/linux/modules/lib.mk
index 81ceb1f76c..d4d44ad8f0 100644
--- a/package/kernel/linux/modules/lib.mk
+++ b/package/kernel/linux/modules/lib.mk
@@ -152,13 +152,15 @@ define KernelPackage/lib-lz4
DEPENDS:=+kmod-crypto-acompress
KCONFIG:= \
CONFIG_CRYPTO_LZ4 \
+ CONFIG_CRYPTO_LZ4HC \
CONFIG_LZ4_COMPRESS \
CONFIG_LZ4_DECOMPRESS
FILES:= \
$(LINUX_DIR)/crypto/lz4.ko \
$(LINUX_DIR)/lib/lz4/lz4_compress.ko \
+ $(LINUX_DIR)/lib/lz4/lz4hc_compress.ko \
$(LINUX_DIR)/lib/lz4/lz4_decompress.ko
- AUTOLOAD:=$(call AutoProbe,lz4 lz4_compress lz4_decompress)
+ AUTOLOAD:=$(call AutoProbe,lz4 lz4_compress lz4hc_compress lz4_decompress)
endef
define KernelPackage/lib-lz4/description
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 58dd2d6c25..c5f944ed31 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -1010,6 +1010,10 @@ define KernelPackage/zram/config
bool "lz4"
select PACKAGE_kmod-lib-lz4
+ config ZRAM_DEF_COMP_LZ4HC
+ bool "lz4-hc"
+ select PACKAGE_kmod-lib-lz4hc
+
config ZRAM_DEF_COMP_ZSTD
bool "zstd"
select PACKAGE_kmod-lib-zstd