aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJohn Audia <therealgraysky@proton.me>2022-05-30 08:45:46 -0400
committerHauke Mehrtens <hauke@hauke-m.de>2022-06-06 19:20:02 +0200
commitcd634afe6cb6565eb6865931c8d73d97cab3600a (patch)
tree7ea876f3904338d08be5bf127c1af0e05008ebba /package
parentb789a588b1c55fe1df7e2d6ae1c4f84b96a03a95 (diff)
downloadupstream-cd634afe6cb6565eb6865931c8d73d97cab3600a.tar.gz
upstream-cd634afe6cb6565eb6865931c8d73d97cab3600a.tar.bz2
upstream-cd634afe6cb6565eb6865931c8d73d97cab3600a.zip
kernel: bump 5.10 to 5.10.119
Delete the crypto-lib-blake2s kmod package, as BLAKE2s is now built-in. Patches automatically rebased. Build system: x86_64 Build-tested: ipq806x/R7800, x86/64 Signed-off-by: John Audia <therealgraysky@proton.me>
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/crypto.mk42
-rw-r--r--package/kernel/linux/modules/netsupport.mk1
2 files changed, 0 insertions, 43 deletions
diff --git a/package/kernel/linux/modules/crypto.mk b/package/kernel/linux/modules/crypto.mk
index cf2cf6c3ac..d43100703e 100644
--- a/package/kernel/linux/modules/crypto.mk
+++ b/package/kernel/linux/modules/crypto.mk
@@ -458,48 +458,6 @@ endef
$(eval $(call KernelPackage,crypto-kpp))
-
-define KernelPackage/crypto-lib-blake2s
- TITLE:=BLAKE2s hash function library
- KCONFIG:=CONFIG_CRYPTO_LIB_BLAKE2S
- HIDDEN:=1
- FILES:=$(LINUX_DIR)/lib/crypto/libblake2s.ko
- $(call AddDepends/crypto,+PACKAGE_kmod-crypto-hash:kmod-crypto-hash)
-endef
-
-define KernelPackage/crypto-lib-blake2s/config
- imply PACKAGE_kmod-crypto-hash
-endef
-
-define KernelPackage/crypto-lib-blake2s/x86/64
- KCONFIG+=CONFIG_CRYPTO_BLAKE2S_X86
- FILES+=\
- $(LINUX_DIR)/lib/crypto/libblake2s-generic.ko \
- $(LINUX_DIR)/arch/x86/crypto/blake2s-x86_64.ko
-endef
-
-define KernelPackage/crypto-lib-blake2s/arm
- KCONFIG+=CONFIG_CRYPTO_BLAKE2S_ARM
- FILES+=\
- $(LINUX_DIR)/lib/crypto/libblake2s-generic.ko@lt5.12 \
- $(LINUX_DIR)/arch/arm/crypto/blake2s-arm.ko@ge5.12
-endef
-
-ifndef KernelPackage/crypto-lib-blake2s/$(CRYPTO_TARGET)
- define KernelPackage/crypto-lib-blake2s/$(CRYPTO_TARGET)
- KCONFIG+=CONFIG_CRYPTO_LIB_BLAKE2S_GENERIC
- FILES+=$(LINUX_DIR)/lib/crypto/libblake2s-generic.ko
- endef
-endif
-
-ifdef KernelPackage/crypto-lib-blake2s/$(ARCH)
- KernelPackage/crypto-lib-blake2s/$(CRYPTO_TARGET)=\
- $(KernelPackage/crypto-lib-blake2s/$(ARCH))
-endif
-
-$(eval $(call KernelPackage,crypto-lib-blake2s))
-
-
define KernelPackage/crypto-lib-chacha20
TITLE:=ChaCha library interface
KCONFIG:=CONFIG_CRYPTO_LIB_CHACHA
diff --git a/package/kernel/linux/modules/netsupport.mk b/package/kernel/linux/modules/netsupport.mk
index 76187df50f..6fb3b57e12 100644
--- a/package/kernel/linux/modules/netsupport.mk
+++ b/package/kernel/linux/modules/netsupport.mk
@@ -1325,7 +1325,6 @@ define KernelPackage/wireguard
SUBMENU:=$(NETWORK_SUPPORT_MENU)
TITLE:=WireGuard secure network tunnel
DEPENDS:= \
- +kmod-crypto-lib-blake2s \
+kmod-crypto-lib-chacha20poly1305 \
+kmod-crypto-lib-curve25519 \
+kmod-udptunnel4 \