aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorChristian Lamparter <chunkeey@gmail.com>2022-05-01 14:10:07 +0200
committerChristian Lamparter <chunkeey@gmail.com>2022-05-07 14:31:21 +0200
commitcb203adda00118501ecf6c74b126abe5fb851e71 (patch)
treee00a5cdd0289233ff3052ce33897ccb444fc88a2 /package
parent203ffc4ca75d43ac32b164c5a474e3ce36999809 (diff)
downloadupstream-cb203adda00118501ecf6c74b126abe5fb851e71.tar.gz
upstream-cb203adda00118501ecf6c74b126abe5fb851e71.tar.bz2
upstream-cb203adda00118501ecf6c74b126abe5fb851e71.zip
kernel: provide i6300esb for qemu/libvirt
the Intel i6300esb is QEMU's default watchdog. And unlike the real "Intel i6300ESB I/O Controller hub" hardware, the i6300esb watchdog driver works on non-x86 targets like for ARM (armvirt 32bit) and potentially virtual PowerPC and MIPS targets (if there was any). Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/other.mk18
1 files changed, 18 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index c8fea034c4..985652e945 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -1274,6 +1274,24 @@ endef
$(eval $(call KernelPackage,tpm-i2c-infineon))
+define KernelPackage/i6300esb-wdt
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=Intel 6300ESB Timer/Watchdog
+ DEPENDS:=@PCI_SUPPORT @!SMALL_FLASH
+ KCONFIG:=CONFIG_I6300ESB_WDT \
+ CONFIG_WATCHDOG_CORE=y
+ FILES:=$(LINUX_DIR)/drivers/$(WATCHDOG_DIR)/i6300esb.ko
+ AUTOLOAD:=$(call AutoLoad,50,i6300esb,1)
+endef
+
+define KernelPackage/i6300esb-wdt/description
+ Kernel module for the watchdog timer built into the Intel
+ 6300ESB controller hub. Also used by QEMU/libvirt.
+endef
+
+$(eval $(call KernelPackage,i6300esb-wdt))
+
+
define KernelPackage/w83627hf-wdt
SUBMENU:=$(OTHER_MENU)
TITLE:=Winbond 83627HF Watchdog Timer