aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorLech Perczak <lech.perczak@gmail.com>2022-04-28 22:59:03 +0200
committerPiotr Dymacz <pepe2k@gmail.com>2022-07-11 14:18:40 +0200
commit6f6c2fb32176b538a8d13d896e7842ae27950925 (patch)
treee46b7256c6f229398a16f7341d7d3f2bdd67c395 /package
parent489d792c85c3b4737bf8810a56b7a5e301f79fd8 (diff)
downloadupstream-6f6c2fb32176b538a8d13d896e7842ae27950925.tar.gz
upstream-6f6c2fb32176b538a8d13d896e7842ae27950925.tar.bz2
upstream-6f6c2fb32176b538a8d13d896e7842ae27950925.zip
linux-firmware: use upstream firmware for cypress-firmware-4339-sdio
Old firmware provided by 'cypress-firmware' suite is not sufficient for AP6335 module used in PICO-PI-IMX7D board to probe successfully. Use the upstream version from linux-firmware instead. At the same time, drop the old firmware from 'cypress-firmware' package. Signed-off-by: Lech Perczak <lech.perczak@gmail.com>
Diffstat (limited to 'package')
-rw-r--r--package/firmware/cypress-firmware/Makefile15
-rw-r--r--package/firmware/linux-firmware/cypress.mk8
2 files changed, 8 insertions, 15 deletions
diff --git a/package/firmware/cypress-firmware/Makefile b/package/firmware/cypress-firmware/Makefile
index c5f41e0cb4..769e69a973 100644
--- a/package/firmware/cypress-firmware/Makefile
+++ b/package/firmware/cypress-firmware/Makefile
@@ -81,21 +81,6 @@ endef
$(eval $(call BuildPackage,cypress-firmware-43362-sdio))
-# Cypress 4339 SDIO Firmware
-define Package/cypress-firmware-4339-sdio
- $(Package/cypress-firmware-default)
- TITLE:=CYW4339 FullMac SDIO firmware
-endef
-
-define Package/cypress-firmware-4339-sdio/install
- $(INSTALL_DIR) $(1)/lib/firmware/brcm
- $(INSTALL_DATA) \
- $(PKG_BUILD_DIR)/firmware/cyfmac4339-sdio.bin \
- $(1)/lib/firmware/brcm/brcmfmac4339-sdio.bin
-endef
-
-$(eval $(call BuildPackage,cypress-firmware-4339-sdio))
-
# Cypress 43430 SDIO Firmware
define Package/cypress-firmware-43430-sdio
$(Package/cypress-firmware-default)
diff --git a/package/firmware/linux-firmware/cypress.mk b/package/firmware/linux-firmware/cypress.mk
new file mode 100644
index 0000000000..2f5b66fecf
--- /dev/null
+++ b/package/firmware/linux-firmware/cypress.mk
@@ -0,0 +1,8 @@
+Package/cypress-firmware-4339-sdio = $(call Package/firmware-default,Broadcom BCM4339 FullMac SDIO firmware)
+define Package/cypress-firmware-4339-sdio/install
+ $(INSTALL_DIR) $(1)/lib/firmware/brcm
+ $(INSTALL_DATA) \
+ $(PKG_BUILD_DIR)/cypress/cyfmac4339-sdio.bin \
+ $(1)/lib/firmware/brcm/brcmfmac4339-sdio.bin
+endef
+$(eval $(call BuildPackage,cypress-firmware-4339-sdio))