aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorXu Wang <xwang1498@gmx.com>2022-05-27 22:21:43 +0000
committerStijn Tintel <stijn@linux-ipv6.be>2022-06-03 12:26:59 +0300
commit197b672c40613a53a78a568a1957f2c23c343c1f (patch)
treea0c6ce5cb2caf5dd2e43a4aee50edca9f18f2797 /package
parent4e1916f71aece40a3b5e8dd8328110fb74c48928 (diff)
downloadupstream-197b672c40613a53a78a568a1957f2c23c343c1f.tar.gz
upstream-197b672c40613a53a78a568a1957f2c23c343c1f.tar.bz2
upstream-197b672c40613a53a78a568a1957f2c23c343c1f.zip
kernel: crypto: add kmod-crypto-chacha20poly1305
Needed by strongSwan IPsec VPN for strongswan-mod-chapoly. Not to be confused with kmod-crypto-LIB-chacha20poly1305, which is an 8-byte nonce version used by wireguard. Signed-off-by: Xu Wang <xwang1498@gmx.com>
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/crypto.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/crypto.mk b/package/kernel/linux/modules/crypto.mk
index 6fd53f6080..cf2cf6c3ac 100644
--- a/package/kernel/linux/modules/crypto.mk
+++ b/package/kernel/linux/modules/crypto.mk
@@ -101,6 +101,18 @@ endef
$(eval $(call KernelPackage,crypto-ccm))
+define KernelPackage/crypto-chacha20poly1305
+ TITLE:=ChaCha20-Poly1305 AEAD support, RFC7539 (used by strongSwan IPsec VPN)
+ DEPENDS:=+kmod-crypto-aead +kmod-crypto-manager
+ KCONFIG:=CONFIG_CRYPTO_CHACHA20POLY1305
+ FILES:=$(LINUX_DIR)/crypto/chacha20poly1305.ko
+ AUTOLOAD:=$(call AutoLoad,09,chacha20poly1305)
+ $(call AddDepends/crypto)
+endef
+
+$(eval $(call KernelPackage,crypto-chacha20poly1305))
+
+
define KernelPackage/crypto-cmac
TITLE:=Support for Cipher-based Message Authentication Code (CMAC)
DEPENDS:=+kmod-crypto-hash