aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorChristian 'Ansuel' Marangi <ansuelsmth@gmail.com>2022-01-22 02:03:18 +0100
committerChristian 'Ansuel' Marangi <ansuelsmth@gmail.com>2022-06-05 16:58:48 +0200
commit156488d1d6bf4480e6c15594ba5ee8689c189b20 (patch)
tree9d17bfc6fcffdc54e93f87f698614854610b1d54 /package
parent1d910fa85224f25218d2a411db1937fb57930fe0 (diff)
downloadupstream-156488d1d6bf4480e6c15594ba5ee8689c189b20.tar.gz
upstream-156488d1d6bf4480e6c15594ba5ee8689c189b20.tar.bz2
upstream-156488d1d6bf4480e6c15594ba5ee8689c189b20.zip
kernel: modules: make ar8216/8327 modularizable
Make ar8216/8327 swconfig driver modularizable and add entry to the netdevices.mk kernel modules file. Signed-off-by: Christian 'Ansuel' Marangi <ansuelsmth@gmail.com>
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/netdevices.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/netdevices.mk b/package/kernel/linux/modules/netdevices.mk
index ec470be5ee..32cd0dcdcd 100644
--- a/package/kernel/linux/modules/netdevices.mk
+++ b/package/kernel/linux/modules/netdevices.mk
@@ -417,6 +417,22 @@ endef
$(eval $(call KernelPackage,switch-rtl8367b))
+define KernelPackage/switch-ar8xxx
+ SUBMENU:=$(NETWORK_DEVICES_MENU)
+ TITLE:=Atheros AR8216/8327 switch support
+ DEPENDS:=+kmod-swconfig
+ KCONFIG:=CONFIG_AR8216_PHY
+ FILES:=$(LINUX_DIR)/drivers/net/phy/ar8xxx.ko
+ AUTOLOAD:=$(call AutoLoad,43,ar8xxx,1)
+endef
+
+define KernelPackage/switch-ar8xxx/description
+ Atheros AR8216/8327 switch support
+endef
+
+$(eval $(call KernelPackage,switch-ar8xxx))
+
+
define KernelPackage/natsemi
SUBMENU:=$(NETWORK_DEVICES_MENU)
TITLE:=National Semiconductor DP8381x series