aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2023-07-26 13:20:43 +0200
committerFelix Fietkau <nbd@nbd.name>2023-08-26 13:30:25 +0200
commit104178a990d1bf72fae73deeb26f37346575205b (patch)
tree0914157f95cdae4e73ff1391701e1a43620aa455 /package
parente74a4b509fd970818086d749caf1d8e68a4f4f7b (diff)
downloadupstream-104178a990d1bf72fae73deeb26f37346575205b.tar.gz
upstream-104178a990d1bf72fae73deeb26f37346575205b.tar.bz2
upstream-104178a990d1bf72fae73deeb26f37346575205b.zip
mt76: update to the latest version
bdf7ca5db707 wifi: mt76: mt7921: move common register definition in mt792x_regs.h ae15d5c6b567 wifi: mt76: mt7921: convert acpisar and clc pointers to void 02515b6b90f0 wifi: mt76: mt7921: rename mt7921_vif in mt792x_vif 6ed8a8bdc7b6 wifi: mt76: mt7921: rename mt7921_sta in mt792x_sta 80234e64e7c5 wifi: mt76: mt7921: rename mt7921_phy in mt792x_phy 2485b4222d3d wifi: mt76: mt7921: rename mt7921_dev in mt792x_dev c6fd7cde77e0 wifi: mt76: mt7921: rename mt7921_hif_ops in mt792x_hif_ops 1a1a57b5f8c4 wifi: mt76: mt792x: move shared structure definition in mt792x.h 68508aab4241 wifi: mt76: mt7921: move mt792x_mutex_{acquire/release} in mt792x.h ff306af07e65 wifi: mt76: mt7921: move mt792x_hw_dev in mt792x.h 4b49d659acab wifi: mt76: mt7921: Replace fake flex-arrays with flexible-array members 93f821cce8f5 wifi: mt76: mt792x: introduce mt792x-lib module de7b90721280 wifi: mt76: mt7921: move mac shared code in mt792x-lib module c68ee8a64bef wifi: mt76: mt7921: move dma shared code in mt792x-lib module 8d561811f271 wifi: mt76: mt7921: move debugfs shared code in mt792x-lib module 0034ae289046 wifi: mt76: mt7921: move init shared code in mt792x-lib module 8419c4e793a7 wifi: mt76: mt792x: introduce mt792x_irq_map b7c7fadf228c wifi: mt76: mt792x: move more dma shared code in mt792x_dma 0b1603ce707c wifi: mt76: mt7921: move hif_ops macro in mt792x.h e07540abe87a wifi: mt76: mt7921: move shared runtime-pm code on mt792x-lib 3d65cd7a8dad wifi: mt76: mt7921: move runtime-pm pci code in mt792x-lib 4551f8c838e6 wifi: mt76: mt7921: move acpi_sar code in mt792x-lib module bd84b8ebaff8 wifi: mt76: mt792x: introduce mt792x-usb module 7067ea0f1bab wifi: mt76: mt792x: move mt7921_load_firmware in mt792x-lib module cf752af84c35 wifi: mt76: mt76_connac3: move lmac queue enumeration in mt76_connac3_mac.h 700041dcf773 wifi: mt76: mt792x: move MT7921_PM_TIMEOUT and MT7921_HW_SCAN_TIMEOUT in common code 58b2b90ad89b wifi: mt76: mt7921: move mt7921_dma_init in pci.c 9e4cb87a04cf wifi: mt76: mt7921: move mt7921u_disconnect mt792x-lib c19b62fe6b68 wifi: mt76: testmode: add nla_policy for MT76_TM_ATTR_TX_LENGTH 4904ab2f87cd wifi: mt76: fix return value check in mt76x02_mac_process_rx 1f0fbbee359c wifi: mt76: mt7915: fix tlv length of mt7915_mcu_get_chan_mib_info 24a54ee3a5ec wifi: mt76: mt7915: fix power-limits while chan_switch 80b8bcf0e3ea wifi: mt76: mt7603: rework/fix rx pse hang check a8d9553d8fc4 wifi: mt76: mt7603: improve watchdog reset reliablity c03d84c0d018 wifi: mt76: mt7603: improve stuck beacon handling 85cc58378d25 wifi: mt76: mt7603: add missing register initialization for MT7628 b14c2351ddb8 wifi: mt76: mt7603: disable A-MSDU tx support on MT7628 Signed-off-by: Felix Fietkau <nbd@nbd.name> (cherry picked from commit 6b3737be323f702d5c1c5533db7d7351603dad0f)
Diffstat (limited to 'package')
-rw-r--r--package/kernel/mt76/Makefile36
1 files changed, 30 insertions, 6 deletions
diff --git a/package/kernel/mt76/Makefile b/package/kernel/mt76/Makefile
index 42d0e6a070..78f01c119f 100644
--- a/package/kernel/mt76/Makefile
+++ b/package/kernel/mt76/Makefile
@@ -8,9 +8,9 @@ PKG_LICENSE_FILES:=
PKG_SOURCE_URL:=https://github.com/openwrt/mt76
PKG_SOURCE_PROTO:=git
-PKG_SOURCE_DATE:=2023-07-26
-PKG_SOURCE_VERSION:=cd3dfe39276905307cc028ac8edf2c06963cda23
-PKG_MIRROR_HASH:=413d2d0faa81d834ba13cb9e503e1e3a61e3e071014da6b525a123e5da053f90
+PKG_SOURCE_DATE:=2023-08-14
+PKG_SOURCE_VERSION:=b14c2351ddb8601c322576d84029e463d456caef
+PKG_MIRROR_HASH:=62b5e157ad525424b6857e77ed373e8d39d03af71b057f8b309d8b293d6eac5f
PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
PKG_USE_NINJA:=0
@@ -262,18 +262,34 @@ define KernelPackage/mt7921-firmware
TITLE:=MediaTek MT7921 firmware
endef
+define KernelPackage/mt792x-common
+ $(KernelPackage/mt76-default)
+ TITLE:=MediaTek MT792x wireless driver common code
+ HIDDEN:=1
+ DEPENDS+=+kmod-mt76-connac +@DRIVER_11AX_SUPPORT
+ FILES:= $(PKG_BUILD_DIR)/mt792x-lib.ko
+endef
+
+define KernelPackage/mt792x-usb
+ $(KernelPackage/mt76-default)
+ TITLE:=MediaTek MT792x wireless driver USB code
+ HIDDEN:=1
+ DEPENDS+=+kmod-mt792x-common +kmod-mt76-usb +@DRIVER_11AX_SUPPORT
+ FILES:= $(PKG_BUILD_DIR)/mt792x-usb.ko
+endef
+
define KernelPackage/mt7921-common
$(KernelPackage/mt76-default)
- TITLE:=MediaTek MT7615 wireless driver common code
+ TITLE:=MediaTek MT7921 wireless driver common code
HIDDEN:=1
- DEPENDS+=+kmod-mt76-connac +kmod-mt7921-firmware +@DRIVER_11AX_SUPPORT +kmod-hwmon-core
+ DEPENDS+=+kmod-mt792x-common +kmod-mt7921-firmware +@DRIVER_11AX_SUPPORT +kmod-hwmon-core
FILES:= $(PKG_BUILD_DIR)/mt7921/mt7921-common.ko
endef
define KernelPackage/mt7921u
$(KernelPackage/mt76-default)
TITLE:=MediaTek MT7921U wireless driver
- DEPENDS+=+kmod-mt76-usb +kmod-mt7921-common
+ DEPENDS+=+kmod-mt792x-usb +kmod-mt7921-common
FILES:= $(PKG_BUILD_DIR)/mt7921/mt7921u.ko
AUTOLOAD:=$(call AutoProbe,mt7921u)
endef
@@ -384,6 +400,12 @@ ifdef CONFIG_PACKAGE_kmod-mt7915e
NOSTDINC_FLAGS += -DCONFIG_MT798X_WMAC
endif
endif
+ifdef CONFIG_PACKAGE_kmod-mt792x-common
+ PKG_MAKE_FLAGS += CONFIG_MT792x_LIB=m
+endif
+ifdef CONFIG_PACKAGE_kmod-mt792x-usb
+ PKG_MAKE_FLAGS += CONFIG_MT792x_USB=m
+endif
ifdef CONFIG_PACKAGE_kmod-mt7921-common
PKG_MAKE_FLAGS += CONFIG_MT7921_COMMON=m
endif
@@ -566,6 +588,8 @@ $(eval $(call KernelPackage,mt7916-firmware))
$(eval $(call KernelPackage,mt7981-firmware))
$(eval $(call KernelPackage,mt7986-firmware))
$(eval $(call KernelPackage,mt7921-firmware))
+$(eval $(call KernelPackage,mt792x-common))
+$(eval $(call KernelPackage,mt792x-usb))
$(eval $(call KernelPackage,mt7921-common))
$(eval $(call KernelPackage,mt7921u))
$(eval $(call KernelPackage,mt7921s))