aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorStijn Tintel <stijn@linux-ipv6.be>2022-07-21 18:26:56 +0200
committerStijn Tintel <stijn@linux-ipv6.be>2022-08-15 16:51:50 +0300
commit05775e38a52007397e5460bd87fa1ac957feb2af (patch)
treeed532bda85feca0acc82646ec7d288028b5d3b93 /package
parenta9eb5cce7e5c4996fa6ffc081b5323bfd4735dc2 (diff)
downloadupstream-05775e38a52007397e5460bd87fa1ac957feb2af.tar.gz
upstream-05775e38a52007397e5460bd87fa1ac957feb2af.tar.bz2
upstream-05775e38a52007397e5460bd87fa1ac957feb2af.zip
kernel: extract kmod-sched-act-ipt from kmod-sched
There is only one module in kmod-sched that depends on iptables. Move it to its own kmod package so we can drop the kmod-ipt-core dependency from kmod-sched. This makes it possible to disable all kmod-ipt-* packages without having to disable kmod-sched. Since we now default to firewall4 and nftables, we should avoid iptables dependencies where we can. Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/netsupport.mk21
1 files changed, 18 insertions, 3 deletions
diff --git a/package/kernel/linux/modules/netsupport.mk b/package/kernel/linux/modules/netsupport.mk
index 5369be201f..be0347527d 100644
--- a/package/kernel/linux/modules/netsupport.mk
+++ b/package/kernel/linux/modules/netsupport.mk
@@ -775,6 +775,22 @@ endef
$(eval $(call KernelPackage,sched-act-sample))
+define KernelPackage/sched-act-ipt
+ SUBMENU:=$(NETWORK_SUPPORT_MENU)
+ TITLE:=IPtables targets
+ DEPENDS:=+kmod-ipt-core +kmod-sched-core
+ KCONFIG:=CONFIG_NET_ACT_IPT
+ FILES:=$(LINUX_DIR)/net/sched/act_ipt.ko
+ AUTOLOAD:=$(call AutoProbe, act_ipt)
+endef
+
+define KernelPackage/sched-act-ipt/description
+ Allows to invoke iptables targets after successful classification.
+endef
+
+$(eval $(call KernelPackage,sched-act-ipt))
+
+
define KernelPackage/sched-act-vlan
SUBMENU:=$(NETWORK_SUPPORT_MENU)
TITLE:=Traffic VLAN manipulation
@@ -948,13 +964,13 @@ endef
$(eval $(call KernelPackage,bpf-test))
-SCHED_MODULES_EXTRA = sch_codel sch_dsmark sch_gred sch_multiq sch_sfq sch_teql sch_fq sch_pie act_ipt act_pedit act_simple act_csum em_cmp em_nbyte em_meta em_text
+SCHED_MODULES_EXTRA = sch_codel sch_dsmark sch_gred sch_multiq sch_sfq sch_teql sch_fq sch_pie act_pedit act_simple act_csum em_cmp em_nbyte em_meta em_text
SCHED_FILES_EXTRA = $(foreach mod,$(SCHED_MODULES_EXTRA),$(LINUX_DIR)/net/sched/$(mod).ko)
define KernelPackage/sched
SUBMENU:=$(NETWORK_SUPPORT_MENU)
TITLE:=Extra traffic schedulers
- DEPENDS:=+kmod-sched-core +kmod-ipt-core +kmod-lib-crc32c +kmod-lib-textsearch
+ DEPENDS:=+kmod-sched-core +kmod-lib-crc32c +kmod-lib-textsearch
KCONFIG:= \
CONFIG_NET_SCH_CODEL \
CONFIG_NET_SCH_DSMARK \
@@ -964,7 +980,6 @@ define KernelPackage/sched
CONFIG_NET_SCH_TEQL \
CONFIG_NET_SCH_FQ \
CONFIG_NET_SCH_PIE \
- CONFIG_NET_ACT_IPT \
CONFIG_NET_ACT_PEDIT \
CONFIG_NET_ACT_SIMP \
CONFIG_NET_ACT_CSUM \