aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorAndre Heider <a.heider@gmail.com>2022-07-15 07:59:15 +0200
committerChristian Marangi <ansuelsmth@gmail.com>2022-10-20 17:42:06 +0200
commitedbf9f156f85c90c899a576aff8a9f8aa506d4a5 (patch)
tree1fea5f9d89b389f2ea81d19cedf6f9a3000a8bcd /package
parent802bfe080678b3a8a94868b717bd127afcabc5b7 (diff)
downloadupstream-edbf9f156f85c90c899a576aff8a9f8aa506d4a5.tar.gz
upstream-edbf9f156f85c90c899a576aff8a9f8aa506d4a5.tar.bz2
upstream-edbf9f156f85c90c899a576aff8a9f8aa506d4a5.zip
uboot-fritz4040: build FritzBox 7520 variant
Support was added as variant of 7530 (DEVICE_ALT0_*) in: cb6f4be1 "ipq40xx: add support for FRITZ!Box 7520" u-boot has a distinct config for it [0], built it. [0] https://github.com/chunkeey/FritzBox-4040-UBOOT/pull/6 Signed-off-by: Andre Heider <a.heider@gmail.com> Tested-by: Martin Blumenstingl <martin.blumenstingl@googlemail.com>
Diffstat (limited to 'package')
-rw-r--r--package/boot/uboot-fritz4040/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/package/boot/uboot-fritz4040/Makefile b/package/boot/uboot-fritz4040/Makefile
index 3aa08081bf..e3ff69d0e4 100644
--- a/package/boot/uboot-fritz4040/Makefile
+++ b/package/boot/uboot-fritz4040/Makefile
@@ -41,6 +41,11 @@ define U-Boot/fritz4040
BUILD_DEVICES:=avm_fritzbox-4040
endef
+define U-Boot/fritz7520
+ NAME:=FritzBox 7520
+ BUILD_DEVICES:=avm_fritzbox-7530
+endef
+
define U-Boot/fritz7530
NAME:=FritzBox 7530
BUILD_DEVICES:=avm_fritzbox-7530
@@ -72,6 +77,6 @@ define Package/u-boot/install
$(INSTALL_BIN) $(PKG_BUILD_DIR)/upload-to-f4040.sh $(1)/
endef
-UBOOT_TARGETS := fritz1200 fritz3000 fritz4040 fritz7530
+UBOOT_TARGETS := fritz1200 fritz3000 fritz4040 fritz7520 fritz7530
$(eval $(call BuildPackage/U-Boot))