aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorZoltan HERPAI <wigyori@uid0.hu>2023-01-29 18:26:10 +0100
committerZoltan HERPAI <wigyori@uid0.hu>2023-07-06 17:04:13 +0200
commit4a79a94e37a5b451ef4f9cb1f68917ef0ebd2cf2 (patch)
treea6455bfc30c9f9d62c78bb47223a7764f4f8ab91 /package
parent894b2086fdf91409980df99ffe6ab8808de0302d (diff)
downloadupstream-4a79a94e37a5b451ef4f9cb1f68917ef0ebd2cf2.tar.gz
upstream-4a79a94e37a5b451ef4f9cb1f68917ef0ebd2cf2.tar.bz2
upstream-4a79a94e37a5b451ef4f9cb1f68917ef0ebd2cf2.zip
mxs: rework image generation
Migrate to "new" image generation method. Device profiles will be generated based on image/Makefile instead of profiles/ , which will also allow to automatically build images for all supported devices via buildbot. Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
Diffstat (limited to 'package')
-rw-r--r--package/boot/uboot-mxs/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/package/boot/uboot-mxs/Makefile b/package/boot/uboot-mxs/Makefile
index 6ae767f677..afd73e191b 100644
--- a/package/boot/uboot-mxs/Makefile
+++ b/package/boot/uboot-mxs/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_VERSION:=2020.04
-PKG_RELEASE:=5
+PKG_RELEASE:=6
PKG_HASH:=fe732aaf037d9cc3c0909bad8362af366ae964bbdac6913a34081ff4ad565372
@@ -27,10 +27,12 @@ endef
define U-Boot/mx23_olinuxino
NAME:=Olinuxino i.MX233
+ BUILD_DEVICES:=olinuxino_maxi olinuxino_micro
endef
define U-Boot/duckbill
NAME:=I2SE Duckbill
+ BUILD_DEVICES:=i2se_duckbill
endef
UBOOT_TARGETS := \
@@ -40,8 +42,12 @@ UBOOT_TARGETS := \
UBOOT_MAKE_FLAGS += $(UBOOT_IMAGE)
define Build/InstallDev
- $(INSTALL_DIR) $(STAGING_DIR_IMAGE)
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/$(UBOOT_IMAGE) $(STAGING_DIR_IMAGE)/$(BUILD_VARIANT)-$(UBOOT_IMAGE)
+ $(foreach device,$(BUILD_DEVICES), \
+ $(INSTALL_DIR) $(STAGING_DIR_IMAGE)/$(device)
+ )
+ $(foreach device,$(BUILD_DEVICES), \
+ $(CP) $(patsubst %,$(PKG_BUILD_DIR)/%,$(UBOOT_IMAGE)) $(STAGING_DIR_IMAGE)/$(device)/
+ )
endef
$(eval $(call BuildPackage/U-Boot))