aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorRobert Marko <robimarko@gmail.com>2021-12-21 13:24:01 +0100
committerRobert Marko <robimarko@gmail.com>2023-01-16 12:42:23 +0100
commitaf6da888146f0307a2c3c803c473318750c70920 (patch)
treee11573182045b0a6f82be39e7319e8b6e231a1f4 /package
parentc01641bcc7236d2e2de3ea65444b0cf2898df351 (diff)
downloadupstream-af6da888146f0307a2c3c803c473318750c70920.tar.gz
upstream-af6da888146f0307a2c3c803c473318750c70920.tar.bz2
upstream-af6da888146f0307a2c3c803c473318750c70920.zip
firmware: add ath11k-firmware package
Package ath11k firmware for AHB devices as well as QCN9074 which is a non consumer card targeted as a companion for QCA WiSoC-s. linux-firmware is always out of date for these, so fetch them from Kalle-s repo like we do for ath10k. Signed-off-by: Robert Marko <robimarko@gmail.com>
Diffstat (limited to 'package')
-rw-r--r--package/firmware/ath11k-firmware/Makefile66
1 files changed, 66 insertions, 0 deletions
diff --git a/package/firmware/ath11k-firmware/Makefile b/package/firmware/ath11k-firmware/Makefile
new file mode 100644
index 0000000000..b3163cd1cb
--- /dev/null
+++ b/package/firmware/ath11k-firmware/Makefile
@@ -0,0 +1,66 @@
+#
+# Copyright (C) 2022 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=ath11k-firmware
+PKG_SOURCE_DATE:=2022-12-14
+PKG_SOURCE_VERSION:=ab1229f94591ec4ffb16410e359b7f618be75a33
+PKG_MIRROR_HASH:=48a2526971e56a3be1c80b72cd82b9932c196b4ab9b7d5dc35117f0548a8fe57
+PKG_RELEASE:=1
+
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL:=https://github.com/kvalo/ath11k-firmware.git
+
+PKG_LICENSE_FILES:=LICENSE.qca_firmware
+
+PKG_MAINTAINER:=Robert Marko <robimarko@gmail.com>
+
+include $(INCLUDE_DIR)/package.mk
+
+RSTRIP:=:
+STRIP:=:
+
+define Package/ath11k-firmware-default
+ SECTION:=firmware
+ CATEGORY:=Firmware
+ URL:=$(PKG_SOURCE_URL)
+ DEPENDS:=
+endef
+
+define Package/ath11k-firmware-ipq8074
+$(Package/ath11k-firmware-default)
+ TITLE:=IPQ8074 ath11k firmware
+endef
+
+define Package/ath11k-firmware-qcn9074
+$(Package/ath11k-firmware-default)
+ TITLE:=QCN9074 ath11k firmware
+endef
+
+define Build/Compile
+
+endef
+
+define Package/ath11k-firmware-ipq8074/install
+ $(INSTALL_DIR) $(1)/lib/firmware/IPQ8074
+ $(INSTALL_DATA) \
+ $(PKG_BUILD_DIR)/IPQ8074/hw2.0/2.5.0.1/WLAN.HK.2.5.0.1-01208-QCAHKSWPL_SILICONZ-1/* \
+ $(1)/lib/firmware/IPQ8074/
+endef
+
+define Package/ath11k-firmware-qcn9074/install
+ $(INSTALL_DIR) $(1)/lib/firmware/ath11k/QCN9074/hw1.0
+ $(INSTALL_DATA) \
+ $(PKG_BUILD_DIR)/QCN9074/hw1.0/2.5.0.1/WLAN.HK.2.5.0.1-01208-QCAHKSWPL_SILICONZ-1/* \
+ $(1)/lib/firmware/ath11k/QCN9074/hw1.0/
+ $(INSTALL_BIN) \
+ $(PKG_BUILD_DIR)/QCN9074/hw1.0/board-2.bin $(1)/lib/firmware/ath11k/QCN9074/hw1.0/board-2.bin
+endef
+
+$(eval $(call BuildPackage,ath11k-firmware-ipq8074))
+$(eval $(call BuildPackage,ath11k-firmware-qcn9074))