aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorEneas U de Queiroz <cotequeiroz@gmail.com>2021-10-17 12:34:05 -0300
committerFelix Fietkau <nbd@nbd.name>2021-11-01 20:18:55 +0100
commit93a42cf16e2b2f09c9c8e91285038d482f1a75f3 (patch)
treea512f8f67c8279f7959d54743b4ad7af6ce893f3 /package
parent67f9245ee57eaf47093275670b227c7911f485d4 (diff)
downloadupstream-93a42cf16e2b2f09c9c8e91285038d482f1a75f3.tar.gz
upstream-93a42cf16e2b2f09c9c8e91285038d482f1a75f3.tar.bz2
upstream-93a42cf16e2b2f09c9c8e91285038d482f1a75f3.zip
f2fstools: set each library package VARIANT
Set the different libf2fs packages's VARIANT, so that the right settings will be used by each different variant, if they are both being built. Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
Diffstat (limited to 'package')
-rw-r--r--package/utils/f2fs-tools/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/utils/f2fs-tools/Makefile b/package/utils/f2fs-tools/Makefile
index 0d243302c2..44ab63c403 100644
--- a/package/utils/f2fs-tools/Makefile
+++ b/package/utils/f2fs-tools/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=f2fs-tools
PKG_VERSION:=1.14.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://git.kernel.org/pub/scm/linux/kernel/git/jaegeuk/f2fs-tools.git/snapshot/
@@ -85,6 +85,7 @@ define Package/libf2fs
DEPENDS:=+libuuid
ABI_VERSION:=6
CONFLICTS:=libf2fs-selinux
+ VARIANT:=default
endef
define Package/libf2fs-selinux
@@ -93,6 +94,7 @@ define Package/libf2fs-selinux
TITLE:=Library for Flash-Friendly File System (F2FS) tools with SELinux support
DEPENDS:=+libuuid +libselinux
ABI_VERSION:=6
+ VARIANT:=selinux
endef
CONFIGURE_ARGS += \