aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorEneas U de Queiroz <cotequeiroz@gmail.com>2021-10-21 10:35:41 -0300
committerFelix Fietkau <nbd@nbd.name>2021-11-01 20:18:55 +0100
commit4ea0cfe810bd3e0f8c3470eb79a3ec8019b07487 (patch)
tree8cdd49b3884fd699a05187a2464132236c44b68c /package
parent93a42cf16e2b2f09c9c8e91285038d482f1a75f3 (diff)
downloadupstream-4ea0cfe810bd3e0f8c3470eb79a3ec8019b07487.tar.gz
upstream-4ea0cfe810bd3e0f8c3470eb79a3ec8019b07487.tar.bz2
upstream-4ea0cfe810bd3e0f8c3470eb79a3ec8019b07487.zip
iproute2: Avoid unnecessary package rebuilds
Build the tc-mod-iptables before the tc-tiny and tc-full packages. This avoids unnecessary package rebuild when calling make back to back. Before this change, tc-mod-iptables will be built after the main tc binary packages. Both tc-tiny and tc-full depend on tc-mod-ipables. If make is called after the packages are already built, it will check the timestamps of both packages, and will rebuild the main binaries, since the module package will be newer than the tc package. Calling BuildPackage,mod-iptables first ensures that its variant gets built before the other packages' variants. Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
Diffstat (limited to 'package')
-rw-r--r--package/network/utils/iproute2/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/network/utils/iproute2/Makefile b/package/network/utils/iproute2/Makefile
index cfcdb8cc53..ca3cb4753a 100644
--- a/package/network/utils/iproute2/Makefile
+++ b/package/network/utils/iproute2/Makefile
@@ -232,9 +232,11 @@ endef
$(eval $(call BuildPackage,ip-tiny))
$(eval $(call BuildPackage,ip-full))
+# build tc-mod-iptables before its dependents, to avoid
+# spurious rebuilds when building multiple variants.
+$(eval $(call BuildPackage,tc-mod-iptables))
$(eval $(call BuildPackage,tc-tiny))
$(eval $(call BuildPackage,tc-full))
-$(eval $(call BuildPackage,tc-mod-iptables))
$(eval $(call BuildPackage,genl))
$(eval $(call BuildPackage,ip-bridge))
$(eval $(call BuildPackage,ss))