aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorMauri Sandberg <maukka@ext.kapsi.fi>2022-02-06 01:07:08 +0200
committerPetr Štetiar <ynezz@true.cz>2022-02-19 13:10:01 +0100
commit15f0074beb55f85ee1de6a34a4c7758f5616f9e1 (patch)
tree39d67640820b3dd593aae97faeef0bd4409d8e5f /package
parent966de48813e68c4e5447055cbb50ea1ab2e8d66c (diff)
downloadupstream-15f0074beb55f85ee1de6a34a4c7758f5616f9e1.tar.gz
upstream-15f0074beb55f85ee1de6a34a4c7758f5616f9e1.tar.bz2
upstream-15f0074beb55f85ee1de6a34a4c7758f5616f9e1.zip
kernel: add package kmod-multiplexer
Adds new kernel module for GPIO controlled multiplexer support. Signed-off-by: Mauri Sandberg <maukka@ext.kapsi.fi> Signed-off-by: Petr Štetiar <ynezz@true.cz> [missing commit description]
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/multiplexer.mk34
1 files changed, 34 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/multiplexer.mk b/package/kernel/linux/modules/multiplexer.mk
new file mode 100644
index 0000000000..135fc62c6d
--- /dev/null
+++ b/package/kernel/linux/modules/multiplexer.mk
@@ -0,0 +1,34 @@
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+MENU_TITLE:=Multiplexer Support
+
+define KernelPackage/mux-core
+ SUBMENU:=$(MENU_TITLE)
+ TITLE:=Multiplexer Support
+ KCONFIG:=CONFIG_MULTIPLEXER
+ FILES:=$(LINUX_DIR)/drivers/mux/mux-core.ko
+ AUTOLOAD:=$(call AutoLoad,25,mux-core,1)
+endef
+
+define KernelPackage/mux-core/description
+ Kernel module for multiplexer support
+endef
+
+$(eval $(call KernelPackage,mux-core))
+
+define KernelPackage/mux-gpio
+ SUBMENU:=$(MENU_TITLE)
+ TITLE:=GPIO-controlled Multiplexer controller
+ KCONFIG:=CONFIG_MUX_GPIO
+ DEPENDS:=@GPIO_SUPPORT kmod-mux-core
+ FILES:=$(LINUX_DIR)/drivers/mux/mux-gpio.ko
+ AUTOLOAD:=$(call AutoLoad,25,mux-gpio,1)
+endef
+
+define KernelPackage/mux-gpio/description
+ Kernel modules for GPIO-controlled Multiplexer controller
+endef
+
+$(eval $(call KernelPackage,mux-gpio))