aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorAndre Heider <a.heider@gmail.com>2021-10-13 12:51:22 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2021-10-24 18:00:49 +0200
commitf262d2aae136d2fe60c3b7314a4a0c5f30d79062 (patch)
tree6f652454977fc70b63df58eee5d1a63f3f04fd16 /package
parentb428f187f0db70a0a7166895ac9d159104ae5708 (diff)
downloadupstream-f262d2aae136d2fe60c3b7314a4a0c5f30d79062.tar.gz
upstream-f262d2aae136d2fe60c3b7314a4a0c5f30d79062.tar.bz2
upstream-f262d2aae136d2fe60c3b7314a4a0c5f30d79062.zip
u-boot.mk: fix pkg-config usage
Using Host/Exports doesn't work as intended, explicitly add the required vars so that u-boot finds the required libraries when building its tools. Signed-off-by: Andre Heider <a.heider@gmail.com>
Diffstat (limited to 'package')
-rw-r--r--package/boot/uboot-mediatek/Makefile2
-rw-r--r--package/boot/uboot-mvebu/Makefile2
-rw-r--r--package/boot/uboot-mxs/Makefile2
-rw-r--r--package/boot/uboot-zynq/Makefile2
4 files changed, 0 insertions, 8 deletions
diff --git a/package/boot/uboot-mediatek/Makefile b/package/boot/uboot-mediatek/Makefile
index a5801afa2d..5d9459d461 100644
--- a/package/boot/uboot-mediatek/Makefile
+++ b/package/boot/uboot-mediatek/Makefile
@@ -111,8 +111,6 @@ UBOOT_TARGETS := \
UBOOT_MAKE_FLAGS += $(UBOOT_IMAGE:.fip=.bin)
-Build/Exports:=$(Host/Exports)
-
define Build/fip-image
$(STAGING_DIR_HOST)/bin/fiptool create \
--soc-fw $(STAGING_DIR_IMAGE)/$(BUILD_SUBTARGET)-$(BL2_BOOTDEV)-$(BL2_DDRBLOB)ddr-bl31.bin \
diff --git a/package/boot/uboot-mvebu/Makefile b/package/boot/uboot-mvebu/Makefile
index bf03fdd2b2..e2f2a2a382 100644
--- a/package/boot/uboot-mvebu/Makefile
+++ b/package/boot/uboot-mvebu/Makefile
@@ -53,8 +53,6 @@ UBOOT_TARGETS:= \
espressobin \
uDPU
-Build/Exports:=$(Host/Exports)
-
define Build/Configure
# enable additional options beyond <device>_defconfig
echo CONFIG_CMD_SETEXPR=y >> $(PKG_BUILD_DIR)/configs/$(UBOOT_CONFIG)_defconfig
diff --git a/package/boot/uboot-mxs/Makefile b/package/boot/uboot-mxs/Makefile
index f4211d3a54..3c908874fa 100644
--- a/package/boot/uboot-mxs/Makefile
+++ b/package/boot/uboot-mxs/Makefile
@@ -38,8 +38,6 @@ UBOOT_TARGETS := \
UBOOT_MAKE_FLAGS += $(UBOOT_IMAGE)
-Build/Exports:=$(Host/Exports)
-
define Build/InstallDev
$(INSTALL_DIR) $(STAGING_DIR_IMAGE)
$(INSTALL_BIN) $(PKG_BUILD_DIR)/$(UBOOT_IMAGE) $(STAGING_DIR_IMAGE)/$(BUILD_VARIANT)-$(UBOOT_IMAGE)
diff --git a/package/boot/uboot-zynq/Makefile b/package/boot/uboot-zynq/Makefile
index b6b1dc8b85..c605cfaeb2 100644
--- a/package/boot/uboot-zynq/Makefile
+++ b/package/boot/uboot-zynq/Makefile
@@ -60,6 +60,4 @@ endef
define Package/u-boot/install/default
endef
-Build/Exports:=$(Host/Exports)
-
$(eval $(call BuildPackage/U-Boot))