aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2022-05-28 14:18:06 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2022-06-07 22:28:59 +0200
commitd04a947b6b2fee6359aa6126068f70efaa3e48bc (patch)
tree2dc3c98bb87c6e30e4308d6880c54643936048b8 /package
parent972160a0f7526fad1be9529879f16791a33355f9 (diff)
downloadupstream-d04a947b6b2fee6359aa6126068f70efaa3e48bc.tar.gz
upstream-d04a947b6b2fee6359aa6126068f70efaa3e48bc.tar.bz2
upstream-d04a947b6b2fee6359aa6126068f70efaa3e48bc.zip
uboot-imx: fix wrong make flags overriding
Buidbots are currently choking on the following compile error: In file included from tools/aisimage.c:9: include/image.h:1133:12: fatal error: openssl/evp.h: No such file or directory # include <openssl/evp.h> ^~~~~~~~~~~~~~~ compilation terminated. This is caused by a complete overriding of make flags which are provided correctly in `UBOOT_MAKE_FLAGS` variable, but currently overriden instead of extended. This then leads to the usage of build host include dirs, which are not available. Fix it by extending `UBOOT_MAKE_FLAGS` variable in all device recipes. Signed-off-by: Petr Štetiar <ynezz@true.cz> (cherry picked from commit 481339a0426698adaa0254b479807efde0428de9)
Diffstat (limited to 'package')
-rw-r--r--package/boot/uboot-imx/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/boot/uboot-imx/Makefile b/package/boot/uboot-imx/Makefile
index 2faa48bd73..cc43269782 100644
--- a/package/boot/uboot-imx/Makefile
+++ b/package/boot/uboot-imx/Makefile
@@ -23,7 +23,7 @@ endef
define U-Boot/apalis_imx6
NAME:=Toradex Apalis
UBOOT_IMAGE:=SPL u-boot.img u-boot-with-spl.imx
- UBOOT_MAKE_FLAGS:=SPL u-boot.img u-boot-with-spl.imx
+ UBOOT_MAKE_FLAGS+=SPL u-boot.img u-boot-with-spl.imx
BUILD_SUBTARGET:=cortexa9
BUILD_DEVICES:=toradex_apalis
endef
@@ -31,7 +31,7 @@ endef
define U-Boot/mx6cuboxi
NAME:=SolidRun Cubox-i boards
UBOOT_IMAGE:=SPL u-boot.img
- UBOOT_MAKE_FLAGS:=SPL u-boot.img
+ UBOOT_MAKE_FLAGS+=SPL u-boot.img
BUILD_SUBTARGET:=cortexa9
BUILD_DEVICES:=solidrun_cubox-i
endef