aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorChristian Lamparter <chunkeey@gmail.com>2022-02-17 16:10:42 +0100
committerChristian Lamparter <chunkeey@gmail.com>2022-02-19 19:34:18 +0100
commit2aa97ecb59e9bc654c14af78337bef02e08965bf (patch)
tree90a4c7a355ac732c744cc119d70f5d3d5e10cba6 /package
parent2db231e77a3a547a6635d16cdf97f9128a8bd277 (diff)
downloadupstream-2aa97ecb59e9bc654c14af78337bef02e08965bf.tar.gz
upstream-2aa97ecb59e9bc654c14af78337bef02e08965bf.tar.bz2
upstream-2aa97ecb59e9bc654c14af78337bef02e08965bf.zip
kernel: add kmod-hwmon-lm70 support
package hwmon's lm70.ko. This module supports the National Semiconductor/TI LM70,LM71,LM74 and TI TMP121,TMP122,TMP123 and TMP124 chips (all SPI). Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/hwmon.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/hwmon.mk b/package/kernel/linux/modules/hwmon.mk
index 943b87cd4c..b75c741ba0 100644
--- a/package/kernel/linux/modules/hwmon.mk
+++ b/package/kernel/linux/modules/hwmon.mk
@@ -213,6 +213,23 @@ endef
$(eval $(call KernelPackage,hwmon-lm63))
+define KernelPackage/hwmon-lm70
+ TITLE:=LM70 monitoring support
+ KCONFIG:=CONFIG_SENSORS_LM70 \
+ CONFIG_SPI=y \
+ CONFIG_SPI_MASTER=y
+ FILES:=$(LINUX_DIR)/drivers/hwmon/lm70.ko
+ AUTOLOAD:=$(call AutoProbe,lm70)
+ $(call AddDepends/hwmon)
+endef
+
+define KernelPackage/hwmon-lm70/description
+ Kernel module for lm70 and compatible thermal monitor chip
+endef
+
+$(eval $(call KernelPackage,hwmon-lm70))
+
+
define KernelPackage/hwmon-lm75
TITLE:=LM75 monitoring support
KCONFIG:=CONFIG_SENSORS_LM75