aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2022-01-13 08:50:19 +0100
committerPaul Spooren <mail@aparcar.org>2022-01-14 00:42:28 +0100
commit0637093e8cb0e4cfb94dfcfe7b57afc23bf88852 (patch)
treece0e7d116c99ec384a1ea8f3b6b0ff31c4652d75 /package
parent83b14ec026d611e3c07eedd4869db08ca682d46d (diff)
downloadupstream-0637093e8cb0e4cfb94dfcfe7b57afc23bf88852.tar.gz
upstream-0637093e8cb0e4cfb94dfcfe7b57afc23bf88852.tar.bz2
upstream-0637093e8cb0e4cfb94dfcfe7b57afc23bf88852.zip
iptables: enable nftable support by default
OpenWrt plans to move over to firewall4 which uses nftables under the hood. To allow a smooth migration the package `iptables-nft` offer a transparent wrapper to apply iptables rules to nftables. Without the config option for nftables the package isn't installed and therefore can't be tested. This commit enabled it and therefore provides the wrapper. The size of the iptables package increases from 25436 to 26500 Bytes. Signed-off-by: Paul Spooren <mail@aparcar.org>
Diffstat (limited to 'package')
-rw-r--r--package/network/utils/iptables/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/network/utils/iptables/Makefile b/package/network/utils/iptables/Makefile
index 42d9af14b0..6aee5c6caf 100644
--- a/package/network/utils/iptables/Makefile
+++ b/package/network/utils/iptables/Makefile
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=iptables
PKG_VERSION:=1.8.7
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE_URL:=https://netfilter.org/projects/iptables/files
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@@ -60,7 +60,7 @@ define Package/iptables/config
config IPTABLES_NFTABLES
bool "Enable Nftables support"
- default n
+ default y
help
This enable nftables support in iptables.
endef