aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJosef Schlehofer <pepe.schlehofer@gmail.com>2022-04-28 15:50:20 +0200
committerPetr Štetiar <ynezz@true.cz>2022-06-14 21:41:35 +0200
commitb65e4d7c5fcc50325b063725f75ab476552d97a6 (patch)
treea753745f7edd6bd2f6c6312900326a35260d6581 /package
parent68a6d7aaabde681addada967be21f7eb298c67f1 (diff)
downloadupstream-b65e4d7c5fcc50325b063725f75ab476552d97a6.tar.gz
upstream-b65e4d7c5fcc50325b063725f75ab476552d97a6.tar.bz2
upstream-b65e4d7c5fcc50325b063725f75ab476552d97a6.zip
uboot-mvebu: remove enabled CONFIG_CMD_SETEXPR
We don't need to make sure that we want to have enabled CONFIG_CMD_SETEXPR by default, since this is already done in U-boot [1]. This was actually needed only for clearfog board [2], which was added in commit: da0005a6d08ae33d958a6d8a6c0c12dc07b5b2b8 ("uboot-mvebu: add patch to enable setexpr for clearfog boards) and send to U-boot to fix it properly. After a while, there was added support for Turris Omnia, which uses setexpr as well [3], but for this board, there are no fixes needed in U-boot and that's why we can remove this option here. It is helpful with shell scripting. If some downstream distributions are using it, they should correct it in defconfig for related boards. [1] https://source.denx.de/u-boot/u-boot/-/blob/e95afa56753cebcd20a5114b6d121f281b789006/cmd/Kconfig#L1504 [2] https://github.com/openwrt/openwrt/blob/852126680e21edc71c0c66561ae5a6d7479dcc67/target/linux/mvebu/image/clearfog.bootscript#L7 [3] https://github.com/openwrt/openwrt/blob/852126680e21edc71c0c66561ae5a6d7479dcc67/target/linux/mvebu/image/turris-omnia.bootscript#L2 Signed-off-by: Josef Schlehofer <pepe.schlehofer@gmail.com> (cherry picked from commit 69cef74c671cb7fa738a5a4c9a283c29f45326c7)
Diffstat (limited to 'package')
-rw-r--r--package/boot/uboot-mvebu/Makefile7
1 files changed, 0 insertions, 7 deletions
diff --git a/package/boot/uboot-mvebu/Makefile b/package/boot/uboot-mvebu/Makefile
index 566f45ffed..a154d15dc1 100644
--- a/package/boot/uboot-mvebu/Makefile
+++ b/package/boot/uboot-mvebu/Makefile
@@ -62,13 +62,6 @@ UBOOT_TARGETS:= \
espressobin \
uDPU
-define Build/Configure
- # enable additional options beyond <device>_defconfig
- echo CONFIG_CMD_SETEXPR=y >> $(PKG_BUILD_DIR)/configs/$(UBOOT_CONFIG)_defconfig
-
- $(call Build/Configure/U-Boot)
-endef
-
define Package/u-boot/install
$(if $(findstring cortexa53,$(BUILD_SUBTARGET)),,$(Package/u-boot/install/default))
endef