aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJan Hoffmann <jan@3e8.eu>2022-03-13 22:14:36 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2022-06-07 21:36:58 +0200
commit642d6c0c6d69dba27d841f6e3e06f866969b0609 (patch)
tree72ef1be883d88a900736025d886df9122880527d /package
parente56836dfc1353c49d43323b75d68ebc3456c6cff (diff)
downloadupstream-642d6c0c6d69dba27d841f6e3e06f866969b0609.tar.gz
upstream-642d6c0c6d69dba27d841f6e3e06f866969b0609.tar.bz2
upstream-642d6c0c6d69dba27d841f6e3e06f866969b0609.zip
ltq-vdsl-mei: enable vectoring error sample callback
This re-enables the vectoring error sample callback and adds a dependency to the corresponding driver. Tested-by: Martin Blumenstingl <martin.blumenstingl@googlemail.com> Signed-off-by: Jan Hoffmann <jan@3e8.eu> (cherry picked from commit 93f0e1f922ec1351d429259db942f10147e624ff)
Diffstat (limited to 'package')
-rw-r--r--package/kernel/lantiq/ltq-vdsl-mei/Makefile4
-rw-r--r--package/kernel/lantiq/ltq-vdsl-mei/patches/100-compat.patch11
2 files changed, 2 insertions, 13 deletions
diff --git a/package/kernel/lantiq/ltq-vdsl-mei/Makefile b/package/kernel/lantiq/ltq-vdsl-mei/Makefile
index 796918549a..d4a5ea720b 100644
--- a/package/kernel/lantiq/ltq-vdsl-mei/Makefile
+++ b/package/kernel/lantiq/ltq-vdsl-mei/Makefile
@@ -9,7 +9,7 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=ltq-vdsl-vr9-mei
PKG_VERSION:=1.5.17.6
-PKG_RELEASE:=4
+PKG_RELEASE:=5
PKG_BASE_NAME:=drv_mei_cpe
PKG_SOURCE:=$(PKG_BASE_NAME)-$(PKG_VERSION).tar.gz
@@ -29,7 +29,7 @@ define KernelPackage/ltq-vdsl-vr9-mei
TITLE:=mei driver for vdsl
SECTION:=sys
SUBMENU:=Network Devices
- DEPENDS:=@TARGET_lantiq_xrx200 +kmod-ltq-ifxos
+ DEPENDS:=@TARGET_lantiq_xrx200 +kmod-ltq-ifxos +kmod-ltq-vectoring
FILES:=$(PKG_BUILD_DIR)/src/drv_mei_cpe.ko
AUTOLOAD:=$(call AutoLoad,50,drv_mei_cpe)
endef
diff --git a/package/kernel/lantiq/ltq-vdsl-mei/patches/100-compat.patch b/package/kernel/lantiq/ltq-vdsl-mei/patches/100-compat.patch
index 75e1500171..61ea826cb4 100644
--- a/package/kernel/lantiq/ltq-vdsl-mei/patches/100-compat.patch
+++ b/package/kernel/lantiq/ltq-vdsl-mei/patches/100-compat.patch
@@ -376,17 +376,6 @@
}
IFX_int32_t MEI_PLL_ConfigInit(MEI_DEV_T *pMeiDev)
---- a/src/drv_mei_cpe_dsm.c
-+++ b/src/drv_mei_cpe_dsm.c
-@@ -144,7 +144,7 @@ IFX_void_t MEI_VRX_DSM_DataInit(MEI_DEV_
- memset((IFX_uint8_t *)&pMeiDev->firmwareFeatures, 0x00, sizeof(IOCTL_MEI_firmwareFeatures_t));
- pMeiDev->meiFwDlCount = 0;
-
-- pMeiDev->meiERBbuf.pCallBackFunc = mei_dsm_cb_func_hook;
-+ pMeiDev->meiERBbuf.pCallBackFunc = NULL;
-
- PRN_DBG_USR_NL( MEI_DRV, MEI_DRV_PRN_LEVEL_NORMAL,
- ("MEI_DRV: PP callback function addr = 0x%08X" MEI_DRV_CRLF,
--- a/src/drv_mei_cpe_download_vrx.c
+++ b/src/drv_mei_cpe_download_vrx.c
@@ -3281,12 +3281,14 @@ IFX_int32_t MEI_DEV_IoctlFirmwareDownloa