aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorXu Wang <xwang1498@gmx.com>2022-05-27 22:21:43 +0000
committerStijn Tintel <stijn@linux-ipv6.be>2022-06-11 16:04:40 +0300
commit3cfe050c4a683ecef25d6ded05b1d240921a121a (patch)
tree7fc22c3aa1c46dc3cb6e8cdb30612cc33316f61d /package
parent23f0fea74258cc14cbf321b5130a8d0e8146e7f1 (diff)
downloadupstream-3cfe050c4a683ecef25d6ded05b1d240921a121a.tar.gz
upstream-3cfe050c4a683ecef25d6ded05b1d240921a121a.tar.bz2
upstream-3cfe050c4a683ecef25d6ded05b1d240921a121a.zip
kernel: crypto: add kmod-crypto-chacha20poly1305
Needed by strongSwan IPsec VPN for strongswan-mod-chapoly. Not to be confused with kmod-crypto-LIB-chacha20poly1305, which is an 8-byte nonce version used by wireguard. Signed-off-by: Xu Wang <xwang1498@gmx.com> (cherry picked from commit 197b672c40613a53a78a568a1957f2c23c343c1f)
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/crypto.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/crypto.mk b/package/kernel/linux/modules/crypto.mk
index 445b2e353b..2b0388aa10 100644
--- a/package/kernel/linux/modules/crypto.mk
+++ b/package/kernel/linux/modules/crypto.mk
@@ -101,6 +101,18 @@ endef
$(eval $(call KernelPackage,crypto-ccm))
+define KernelPackage/crypto-chacha20poly1305
+ TITLE:=ChaCha20-Poly1305 AEAD support, RFC7539 (used by strongSwan IPsec VPN)
+ DEPENDS:=+kmod-crypto-aead +kmod-crypto-manager
+ KCONFIG:=CONFIG_CRYPTO_CHACHA20POLY1305
+ FILES:=$(LINUX_DIR)/crypto/chacha20poly1305.ko
+ AUTOLOAD:=$(call AutoLoad,09,chacha20poly1305)
+ $(call AddDepends/crypto)
+endef
+
+$(eval $(call KernelPackage,crypto-chacha20poly1305))
+
+
define KernelPackage/crypto-cmac
TITLE:=Support for Cipher-based Message Authentication Code (CMAC)
DEPENDS:=+kmod-crypto-hash