aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJohn Audia <therealgraysky@proton.me>2022-05-30 08:45:46 -0400
committerHauke Mehrtens <hauke@hauke-m.de>2022-06-07 22:28:59 +0200
commit0ca93670693bc63045b181505d9ff69c4bde5750 (patch)
tree6faa65ab18b1ee4d10b35e8c86b2474a23fa7286 /package
parent49f8a75031c8fb2efc4824166da75f1473cdab6b (diff)
downloadupstream-0ca93670693bc63045b181505d9ff69c4bde5750.tar.gz
upstream-0ca93670693bc63045b181505d9ff69c4bde5750.tar.bz2
upstream-0ca93670693bc63045b181505d9ff69c4bde5750.zip
kernel: bump 5.10 to 5.10.119
Delete the crypto-lib-blake2s kmod package, as BLAKE2s is now built-in. Patches automatically rebased. Build system: x86_64 Build-tested: ipq806x/R7800, x86/64 Signed-off-by: John Audia <therealgraysky@proton.me> (cherry picked from commit cd634afe6cb6565eb6865931c8d73d97cab3600a)
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/crypto.mk23
-rw-r--r--package/kernel/linux/modules/netsupport.mk1
2 files changed, 0 insertions, 24 deletions
diff --git a/package/kernel/linux/modules/crypto.mk b/package/kernel/linux/modules/crypto.mk
index 4097957277..445b2e353b 100644
--- a/package/kernel/linux/modules/crypto.mk
+++ b/package/kernel/linux/modules/crypto.mk
@@ -446,29 +446,6 @@ endef
$(eval $(call KernelPackage,crypto-kpp))
-
-define KernelPackage/crypto-lib-blake2s
- TITLE:=BLAKE2s hash function library
- KCONFIG:=CONFIG_CRYPTO_LIB_BLAKE2S
- HIDDEN:=1
- FILES:= \
- $(LINUX_DIR)/lib/crypto/libblake2s.ko \
- $(LINUX_DIR)/lib/crypto/libblake2s-generic.ko
- $(call AddDepends/crypto,+PACKAGE_kmod-crypto-hash:kmod-crypto-hash)
-endef
-
-define KernelPackage/crypto-lib-blake2s/config
- imply PACKAGE_kmod-crypto-hash
-endef
-
-define KernelPackage/crypto-lib-blake2s/x86/64
- KCONFIG+=CONFIG_CRYPTO_BLAKE2S_X86
- FILES+=$(LINUX_DIR)/arch/x86/crypto/blake2s-x86_64.ko
-endef
-
-$(eval $(call KernelPackage,crypto-lib-blake2s))
-
-
define KernelPackage/crypto-lib-chacha20
TITLE:=ChaCha library interface
KCONFIG:=CONFIG_CRYPTO_LIB_CHACHA
diff --git a/package/kernel/linux/modules/netsupport.mk b/package/kernel/linux/modules/netsupport.mk
index fd9051586a..689efc3722 100644
--- a/package/kernel/linux/modules/netsupport.mk
+++ b/package/kernel/linux/modules/netsupport.mk
@@ -1324,7 +1324,6 @@ define KernelPackage/wireguard
SUBMENU:=$(NETWORK_SUPPORT_MENU)
TITLE:=WireGuard secure network tunnel
DEPENDS:= \
- +kmod-crypto-lib-blake2s \
+kmod-crypto-lib-chacha20poly1305 \
+kmod-crypto-lib-curve25519 \
+kmod-udptunnel4 \