aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorStijn Tintel <stijn@linux-ipv6.be>2021-08-23 14:06:35 +0300
committerStijn Tintel <stijn@linux-ipv6.be>2021-08-23 14:09:42 +0300
commit669d920e278fe00895490d7c1a81774317ff358a (patch)
treeb6edbd5c56d8d4b6940b73bbe0252fc6340f18a7 /package
parent98eb95dd0018d4f21a5b86b323074d5854e1bde3 (diff)
downloadupstream-669d920e278fe00895490d7c1a81774317ff358a.tar.gz
upstream-669d920e278fe00895490d7c1a81774317ff358a.tar.bz2
upstream-669d920e278fe00895490d7c1a81774317ff358a.zip
base-files: fix option to make /var persistent
The option was initially named TARGET_ROOTFS_LN_VAR_TMP, and the check was correct. When renaming the option to something more suitable, the check was changed to check for n, but when an option is not set, it's not n but empty. This results in the check always evaluating to false. Fix the check by checking for y with ifneq. Fixes: 57807f50ded6 ("base-files: add option to make /var persistent") Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
Diffstat (limited to 'package')
-rw-r--r--package/base-files/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 6da3df2b4e..58ad08c63a 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -181,7 +181,7 @@ define Package/base-files/install
mkdir -p $(1)/www
mkdir -p $(1)/root
$(LN) /proc/mounts $(1)/etc/mtab
-ifeq ($(CONFIG_TARGET_ROOTFS_PERSIST_VAR),n)
+ifneq ($(CONFIG_TARGET_ROOTFS_PERSIST_VAR),y)
rm -f $(1)/var
$(LN) tmp $(1)/var
else