aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorEtienne Champetier <champetier.etienne@gmail.com>2022-02-21 16:20:36 -0500
committerHauke Mehrtens <hauke@hauke-m.de>2022-02-28 21:52:01 +0100
commit316c406e62a535d17d654ab8c4f5e84a0485058f (patch)
treea02114447961432edf2ab02a64c752c65854133d /package
parentd35a573004ff21e5a7bbdb896967454c63b7a363 (diff)
downloadupstream-316c406e62a535d17d654ab8c4f5e84a0485058f.tar.gz
upstream-316c406e62a535d17d654ab8c4f5e84a0485058f.tar.bz2
upstream-316c406e62a535d17d654ab8c4f5e84a0485058f.zip
iptables: move IPTABLES_{CONNLABEL,NFTABLES} to libxtables
Those 2 configs are not specific to iptables(-legacy) Signed-off-by: Etienne Champetier <champetier.etienne@gmail.com>
Diffstat (limited to 'package')
-rw-r--r--package/network/utils/iptables/Makefile30
1 files changed, 15 insertions, 15 deletions
diff --git a/package/network/utils/iptables/Makefile b/package/network/utils/iptables/Makefile
index c5310838a3..78d29089a3 100644
--- a/package/network/utils/iptables/Makefile
+++ b/package/network/utils/iptables/Makefile
@@ -47,7 +47,6 @@ endef
define Package/iptables
$(call Package/iptables/Default)
TITLE:=IP firewall administration tool
- MENU:=1
DEPENDS+= +kmod-ipt-core +libip4tc +IPV6:libip6tc +libxtables
ALTERNATIVES:=\
200:/usr/sbin/iptables:/usr/sbin/xtables-legacy-multi \
@@ -55,20 +54,6 @@ $(call Package/iptables/Default)
200:/usr/sbin/iptables-save:/usr/sbin/xtables-legacy-multi
endef
-define Package/iptables/config
- config IPTABLES_CONNLABEL
- bool "Enable Connlabel support"
- default n
- help
- This enable connlabel support in iptables.
-
- config IPTABLES_NFTABLES
- bool "Enable Nftables support"
- default y
- help
- This enable nftables support in iptables.
-endef
-
define Package/iptables/description
IP firewall administration tool.
@@ -525,10 +510,25 @@ define Package/libxtables
SECTION:=libs
CATEGORY:=Libraries
TITLE:=IPv4/IPv6 firewall - shared xtables library
+ MENU:=1
ABI_VERSION:=12
DEPENDS:=+IPTABLES_CONNLABEL:libnetfilter-conntrack
endef
+define Package/libxtables/config
+ config IPTABLES_CONNLABEL
+ bool "Enable Connlabel support"
+ default n
+ help
+ This enable connlabel support in iptables.
+
+ config IPTABLES_NFTABLES
+ bool "Enable Nftables support"
+ default y
+ help
+ This enable nftables support in iptables.
+endef
+
define Package/libxtables-nft
$(call Package/iptables/Default)
SECTION:=libs