aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJosef Schlehofer <josef.schlehofer@nic.cz>2019-05-16 17:23:12 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2021-12-05 18:49:14 +0100
commitfcb82e42dffca99a6e3244b67992df0b573ce38e (patch)
tree0c87bf9f36ee24fffc77aea952d2d2d8d73eb69e /package
parent9f0575a13023c1edbb1518304b25ecab7d34cd58 (diff)
downloadupstream-fcb82e42dffca99a6e3244b67992df0b573ce38e.tar.gz
upstream-fcb82e42dffca99a6e3244b67992df0b573ce38e.tar.bz2
upstream-fcb82e42dffca99a6e3244b67992df0b573ce38e.zip
kernel: btrfs: enable ACL
By default CONFIG_BTRFS_FS_POSIX_ACL is disabled, it should be enabled only when you enable CONFIG_FS_POSIX_ACL. Right now, when you enable CONFIG_FS_POSIX_ACL it will enable CONFIG_BTRFS_FS_POSIX_ACL, but it will be disabled once you install kmod-btrfs. This should prevent it. Btrfs has enabled by default ACL for mount option. More details: https://cateee.net/lkddb/web-lkddb/BTRFS_FS_POSIX_ACL.html https://btrfs.wiki.kernel.org/index.php/Manpage/btrfs(5) Signed-off-by: Josef Schlehofer <josef.schlehofer@nic.cz>
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/fs.mk1
1 files changed, 0 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/fs.mk b/package/kernel/linux/modules/fs.mk
index 7de1a0673c..f9e1b132c7 100644
--- a/package/kernel/linux/modules/fs.mk
+++ b/package/kernel/linux/modules/fs.mk
@@ -70,7 +70,6 @@ define KernelPackage/fs-btrfs
DEPENDS:=+kmod-lib-crc32c +kmod-lib-lzo +kmod-lib-zlib-inflate +kmod-lib-zlib-deflate +kmod-lib-raid6 +kmod-lib-xor +kmod-lib-zstd
KCONFIG:=\
CONFIG_BTRFS_FS \
- CONFIG_BTRFS_FS_POSIX_ACL=n \
CONFIG_BTRFS_FS_CHECK_INTEGRITY=n
FILES:=\
$(LINUX_DIR)/fs/btrfs/btrfs.ko