aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorEtienne Champetier <champetier.etienne@gmail.com>2022-02-28 23:32:53 -0500
committerHauke Mehrtens <hauke@hauke-m.de>2022-03-19 16:13:58 +0100
commitc913be1da1b4688cbfebaa54895624ad5e01c476 (patch)
tree35c24dde54bb372544be1c244288bbd20c663f73 /package
parentafb6824a2c188e5f2610c989a2848bb70e594efb (diff)
downloadupstream-c913be1da1b4688cbfebaa54895624ad5e01c476.tar.gz
upstream-c913be1da1b4688cbfebaa54895624ad5e01c476.tar.bz2
upstream-c913be1da1b4688cbfebaa54895624ad5e01c476.zip
iptables: add xtables-nft package
This allows to install ip6tables-nft without iptables-nft This prepare the addition of {arp,eb}tables-nft Signed-off-by: Etienne Champetier <champetier.etienne@gmail.com>
Diffstat (limited to 'package')
-rw-r--r--package/network/utils/iptables/Makefile17
1 files changed, 14 insertions, 3 deletions
diff --git a/package/network/utils/iptables/Makefile b/package/network/utils/iptables/Makefile
index 4c1119e84f..0220ddf1a5 100644
--- a/package/network/utils/iptables/Makefile
+++ b/package/network/utils/iptables/Makefile
@@ -101,10 +101,16 @@ IP firewall administration tool.
endef
+define Package/xtables-nft
+$(call Package/iptables/Default)
+ TITLE:=IP firewall administration tool nft
+ DEPENDS:=@IPTABLES_NFTABLES +libnftnl +libiptext +IPV6:libiptext6 +libiptext-nft +kmod-nft-compat
+endef
+
define Package/iptables-nft
$(call Package/iptables/Default)
TITLE:=IP firewall administration tool nft
- DEPENDS:=@IPTABLES_NFTABLES +libnftnl +libiptext +IPV6:libiptext6 +libiptext-nft +kmod-ipt-core +kmod-nft-compat
+ DEPENDS:=+kmod-ipt-core +xtables-nft
PROVIDES:=iptables
ALTERNATIVES:=\
300:/usr/sbin/iptables:/usr/sbin/xtables-nft-multi \
@@ -469,7 +475,7 @@ endef
define Package/ip6tables-nft
$(call Package/iptables/Default)
- DEPENDS:=@IPV6 +kmod-ip6tables +iptables-nft
+ DEPENDS:=@IPV6 +kmod-ip6tables +xtables-nft
TITLE:=IP firewall administration tool nft
PROVIDES:=ip6tables
ALTERNATIVES:=\
@@ -655,9 +661,13 @@ define Package/iptables-legacy/install
$(INSTALL_DIR) $(1)/usr/lib/iptables
endef
-define Package/iptables-nft/install
+define Package/xtables-nft/install
$(INSTALL_DIR) $(1)/usr/sbin
$(CP) $(PKG_INSTALL_DIR)/usr/sbin/xtables-nft-multi $(1)/usr/sbin/
+endef
+
+define Package/iptables-nft/install
+ $(INSTALL_DIR) $(1)/usr/sbin
$(CP) $(PKG_INSTALL_DIR)/usr/sbin/iptables-nft{,-restore,-save} $(1)/usr/sbin/
$(CP) $(PKG_INSTALL_DIR)/usr/sbin/iptables{,-restore}-translate $(1)/usr/sbin/
endef
@@ -726,6 +736,7 @@ $(eval $(call BuildPackage,libiptext6))
$(eval $(call BuildPackage,libiptext-nft))
$(eval $(call BuildPackage,xtables-legacy))
$(eval $(call BuildPackage,iptables-legacy))
+$(eval $(call BuildPackage,xtables-nft))
$(eval $(call BuildPackage,iptables-nft))
$(eval $(call BuildPlugin,iptables-mod-conntrack-extra,$(IPT_CONNTRACK_EXTRA-m)))
$(eval $(call BuildPlugin,iptables-mod-conntrack-label,$(IPT_CONNTRACK_LABEL-m)))