aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorOldřich Jedlička <oldium.pro@gmail.com>2021-11-07 20:30:25 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2021-11-29 22:11:15 +0100
commit8d6a534cc12cb4b4d9f0f21324cb752365a71743 (patch)
tree6430e0c8de6a398a5a9c07f2f57bf93c83ba0c54 /package
parent040c02497c56c17d8cf04f9b8b535967d7c3b10e (diff)
downloadupstream-8d6a534cc12cb4b4d9f0f21324cb752365a71743.tar.gz
upstream-8d6a534cc12cb4b4d9f0f21324cb752365a71743.tar.bz2
upstream-8d6a534cc12cb4b4d9f0f21324cb752365a71743.zip
mac80211: fixed missing cfg80211 dependency on kmod-rfkill
When compiling with CONFIG_USE_RFKILL=y, the build fails and mentions that dependency on kmod-rfkill is missing, which is correct [1]. Add this dependency to the Makefile. Depend on +USE_RFKILL and not PACKAGE_kmod-rfkill, because it forces selection of kmod-rfkill package. Other combinations in DEPENDS like USE_RFKILL:kmod-rfkill or (+)PACKAGE_kmod-rfkill:kmod-rfkill do not force selection of kmod-rfkill package. The kmod-rfkill package itself depends on USE_RFKILL, so with +USE_RFKILL in kmod-cfg80211 package it is not possible to select wrong combination of packages. [1] https://linux-wireless.vger.kernel.narkive.com/m8JY9Iks/cfg80211-depends-on-rfkill-or-not Signed-off-by: Oldřich Jedlička <oldium.pro@gmail.com>
Diffstat (limited to 'package')
-rw-r--r--package/kernel/mac80211/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/mac80211/Makefile b/package/kernel/mac80211/Makefile
index 89e078b0c3..e3cf2d3800 100644
--- a/package/kernel/mac80211/Makefile
+++ b/package/kernel/mac80211/Makefile
@@ -97,7 +97,7 @@ PKG_CONFIG_DEPENDS += \
define KernelPackage/cfg80211
$(call KernelPackage/mac80211/Default)
TITLE:=cfg80211 - wireless configuration API
- DEPENDS+= +iw +iwinfo +wireless-regdb
+ DEPENDS+= +iw +iwinfo +wireless-regdb +USE_RFKILL:kmod-rfkill
ABI_VERSION:=$(PKG_VERSION)-$(PKG_RELEASE)
FILES:= \
$(PKG_BUILD_DIR)/compat/compat.ko \