aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorEneas U de Queiroz <cotequeiroz@gmail.com>2021-08-12 10:57:07 -0300
committerHans Dedecker <dedeckeh@gmail.com>2021-08-31 20:35:19 +0200
commit4d0883c011e1f56711f59c2f18315d2cd817dba2 (patch)
tree608cf77e52b1c4f2b84dc32e7f831e45e14dd564 /package
parentbf94c2da3e60fe41b379cf4a7f87763d30fcb601 (diff)
downloadupstream-4d0883c011e1f56711f59c2f18315d2cd817dba2.tar.gz
upstream-4d0883c011e1f56711f59c2f18315d2cd817dba2.tar.bz2
upstream-4d0883c011e1f56711f59c2f18315d2cd817dba2.zip
ethtool: fix recursive dependency
Change the CONFLICTS definition from the alternative package (ethtool-full) to the main one. The CONFLICTS line creates a dependency to the conflicting package. Right now, the dependency would be created in the PACKAGE_ethtool-full symbol: config PACKAGE_ethtool-full depends on m || (PACKAGE_ethtool != y) When the main package is selected by airmon-ng, it selects PACKAGE_ethtool, *depending* on the value of PACKAGE_ethtool-full: config PACKAGE_airmon-ng select PACKAGE_ethtool if PACKAGE_ethtool-full<PACKAGE_airmon-ng In the first block, the value of PACKAGE_ethtool-full depends on the value of PACKAGE_ethtool. In the second block, the opposite is true: the value of PACKAGE_ethtool depends on the value of PACKAGE_ethtool-full. This is a recursive dependency. Fix it by changing the package where the dependency is created, so that only the value of PACKAGE_ethtool will depend on PACKAGE_ethtool-full. Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
Diffstat (limited to 'package')
-rw-r--r--package/network/utils/ethtool/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/package/network/utils/ethtool/Makefile b/package/network/utils/ethtool/Makefile
index a82e5c92fa..9889677a16 100644
--- a/package/network/utils/ethtool/Makefile
+++ b/package/network/utils/ethtool/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=ethtool
PKG_VERSION:=5.13
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
@@ -31,6 +31,7 @@ define Package/ethtool
TITLE:=Display or change ethernet card settings
URL:=http://www.kernel.org/pub/software/network/ethtool/
VARIANT:=tiny
+ CONFLICTS:=ethtool-full
endef
define Package/ethtool-full
@@ -38,8 +39,8 @@ define Package/ethtool-full
TITLE += (full)
VARIANT:=full
PROVIDES:=ethtool
- CONFLICTS:=ethtool
DEPENDS:=+libmnl
+ CONFLICTS:=
endef
define Package/ethtool/description