aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2021-11-06 18:56:20 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2021-11-07 17:08:51 +0100
commit13bd0721d1add0e232991a79a21cfcb468e5c7f3 (patch)
tree0d10573d1a730076dfde86a72f6678bc5ed6ff8f /package
parentc5fa7ec2a6d97597cfcac8d21657026802ff01a2 (diff)
downloadupstream-13bd0721d1add0e232991a79a21cfcb468e5c7f3.tar.gz
upstream-13bd0721d1add0e232991a79a21cfcb468e5c7f3.tar.bz2
upstream-13bd0721d1add0e232991a79a21cfcb468e5c7f3.zip
kernel: Add regmap-i2c dependency to sound-soc-imx-sgtl5000
This dependency is needed on the imx/cortexa7 subtarget. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/sound.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/sound.mk b/package/kernel/linux/modules/sound.mk
index e1d7f72a0f..83b3355f3f 100644
--- a/package/kernel/linux/modules/sound.mk
+++ b/package/kernel/linux/modules/sound.mk
@@ -243,7 +243,7 @@ define KernelPackage/sound-soc-imx-sgtl5000
$(LINUX_DIR)/sound/soc/codecs/snd-soc-sgtl5000.ko \
$(LINUX_DIR)/sound/soc/fsl/snd-soc-imx-sgtl5000.ko
AUTOLOAD:=$(call AutoLoad,57,snd-soc-sgtl5000 snd-soc-imx-sgtl5000)
- DEPENDS:=@TARGET_imx +kmod-sound-soc-imx
+ DEPENDS:=@TARGET_imx +kmod-sound-soc-imx +kmod-regmap-i2c
$(call AddDepends/sound)
endef