aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorTimo Sigurdsson <public_timo.s@silentcreek.de>2021-06-15 23:08:56 +0200
committerPaul Spooren <mail@aparcar.org>2021-07-05 14:03:27 -1000
commit89d21b7f6299b8c3746c1af8671b0dba19f63598 (patch)
treeaee7363ecc0f9e3302976dee44970fb6e2161391 /package
parent72f0733123631e0c20cefcc89d6a81d41d918f20 (diff)
downloadupstream-89d21b7f6299b8c3746c1af8671b0dba19f63598.tar.gz
upstream-89d21b7f6299b8c3746c1af8671b0dba19f63598.tar.bz2
upstream-89d21b7f6299b8c3746c1af8671b0dba19f63598.zip
hostapd: make country3 option configurable
The country3 option in hostapd.conf allows the third octet of the country string to be set. It can be used e.g. to indicate indoor or outdoor use (see hostapd.conf for further details). Make this option configurable but optional in OpenWrt. Signed-off-by: Timo Sigurdsson <public_timo.s@silentcreek.de> [bump PKG_RELEASE, rebase] Signed-off-by: Paul Spooren <mail@aparcar.org> (cherry picked from commit 9f09c1936a4a13b67fcba632f7ca02331f685359) Signed-off-by: Paul Spooren <mail@aparcar.org>
Diffstat (limited to 'package')
-rw-r--r--package/network/services/hostapd/Makefile2
-rw-r--r--package/network/services/hostapd/files/hostapd.sh5
2 files changed, 4 insertions, 3 deletions
diff --git a/package/network/services/hostapd/Makefile b/package/network/services/hostapd/Makefile
index 0779421b8d..628bbbec4d 100644
--- a/package/network/services/hostapd/Makefile
+++ b/package/network/services/hostapd/Makefile
@@ -7,7 +7,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=hostapd
-PKG_RELEASE:=33
+PKG_RELEASE:=34
PKG_SOURCE_URL:=http://w1.fi/hostap.git
PKG_SOURCE_PROTO:=git
diff --git a/package/network/services/hostapd/files/hostapd.sh b/package/network/services/hostapd/files/hostapd.sh
index 87fcaf03b3..ee338a9388 100644
--- a/package/network/services/hostapd/files/hostapd.sh
+++ b/package/network/services/hostapd/files/hostapd.sh
@@ -92,7 +92,7 @@ hostapd_common_add_device_config() {
config_add_array basic_rate
config_add_array supported_rates
- config_add_string country
+ config_add_string country country3
config_add_boolean country_ie doth
config_add_boolean spectrum_mgmt_required
config_add_int local_pwr_constraint
@@ -114,7 +114,7 @@ hostapd_prepare_device_config() {
local base_cfg=
- json_get_vars country country_ie beacon_int:100 dtim_period:2 doth require_mode legacy_rates \
+ json_get_vars country country3 country_ie beacon_int:100 dtim_period:2 doth require_mode legacy_rates \
acs_chan_bias local_pwr_constraint spectrum_mgmt_required airtime_mode cell_density
hostapd_set_log_options base_cfg
@@ -128,6 +128,7 @@ hostapd_prepare_device_config() {
[ -n "$country" ] && {
append base_cfg "country_code=$country" "$N"
+ [ -n "$country3" ] && append base_cfg "country3=$country3" "$N"
[ "$country_ie" -gt 0 ] && {
append base_cfg "ieee80211d=1" "$N"