aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorLeon M. George <leon@georgemail.eu>2021-03-23 11:02:36 +0100
committerRafał Miłecki <rafal@milecki.pl>2021-05-26 08:32:54 +0200
commitef1491694753291d7d7eb0b212b4250ac9388bfc (patch)
tree6c69c44ce42a116a57e82198bf6babf614d02d92 /package
parentf3a0f906b58ec3594cf26473405e85baac7fd774 (diff)
downloadupstream-ef1491694753291d7d7eb0b212b4250ac9388bfc.tar.gz
upstream-ef1491694753291d7d7eb0b212b4250ac9388bfc.tar.bz2
upstream-ef1491694753291d7d7eb0b212b4250ac9388bfc.zip
netifd: read udhcpc user scripts from directory
Placeholder DHCP user scripts were added recently. These files make package-based installations of such scripts more difficult. Pull user callbacks from directories instead to allow packages and users to install co-existing scripts more easily. References: 130118f7a netifd: add a udhcpc.user placeholder script Signed-off-by: Leon M. George <leon@georgemail.eu> Signed-off-by: Hans Dedecker <dedeckeh@gmail.com> [PKG_RELEASE increase] (cherry picked from commit 467c32600cc575fcb67c5f01ad32e02141220ceb)
Diffstat (limited to 'package')
-rw-r--r--package/network/config/netifd/Makefile4
-rwxr-xr-xpackage/network/config/netifd/files/lib/netifd/dhcp.script3
2 files changed, 6 insertions, 1 deletions
diff --git a/package/network/config/netifd/Makefile b/package/network/config/netifd/Makefile
index e4720aa821..7d916b6939 100644
--- a/package/network/config/netifd/Makefile
+++ b/package/network/config/netifd/Makefile
@@ -1,7 +1,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=netifd
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL=$(PROJECT_GIT)/project/netifd.git
@@ -27,6 +27,7 @@ endef
define Package/netifd/conffiles
/etc/udhcpc.user
+/etc/udhcpc.user.d/
endef
TARGET_CFLAGS += \
@@ -44,6 +45,7 @@ define Package/netifd/install
$(INSTALL_DIR) $(1)/sbin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/netifd $(1)/sbin/
$(CP) ./files/* $(1)/
+ $(INSTALL_DIR) $(1)/etc/udhcpc.user.d/
$(CP) $(PKG_BUILD_DIR)/scripts/* $(1)/lib/netifd/
endef
diff --git a/package/network/config/netifd/files/lib/netifd/dhcp.script b/package/network/config/netifd/files/lib/netifd/dhcp.script
index 6585b641d6..e46005d84c 100755
--- a/package/network/config/netifd/files/lib/netifd/dhcp.script
+++ b/package/network/config/netifd/files/lib/netifd/dhcp.script
@@ -112,5 +112,8 @@ esac
# user rules
[ -f /etc/udhcpc.user ] && . /etc/udhcpc.user "$@"
+for f in /etc/udhcpc.user.d/*; do
+ [ -f "$f" ] && (. "$f" "$@")
+done
exit 0