aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2020-07-08 21:11:40 +0200
committerPetr Štetiar <ynezz@true.cz>2020-07-08 21:13:14 +0200
commitbbdd99619c714d338c14982913d3879f0a088c2d (patch)
tree73a910ea5505f61038f19e186425aa6d40042ea2 /package
parentf3921acdf0e030b02735683df0f3d368607bd91f (diff)
downloadupstream-bbdd99619c714d338c14982913d3879f0a088c2d.tar.gz
upstream-bbdd99619c714d338c14982913d3879f0a088c2d.tar.bz2
upstream-bbdd99619c714d338c14982913d3879f0a088c2d.zip
kernel: iscsi-initator: fix missing dependency
Fixes following issue: Package kmod-iscsi-initiator is missing dependencies for the following libraries: crypto_hash.ko Fixes: b88f8202c4ce ("kernel: add iscsi-initator support") Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/block.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/block.mk b/package/kernel/linux/modules/block.mk
index a86c60da2a..faea5cc34e 100644
--- a/package/kernel/linux/modules/block.mk
+++ b/package/kernel/linux/modules/block.mk
@@ -273,7 +273,7 @@ $(eval $(call KernelPackage,dm-raid))
define KernelPackage/iscsi-initiator
SUBMENU:=$(BLOCK_MENU)
TITLE:=iSCSI Initiator over TCP/IP
- DEPENDS:=+kmod-scsi-core
+ DEPENDS:=+kmod-scsi-core +kmod-crypto-hash
KCONFIG:= \
CONFIG_INET \
CONFIG_SCSI_LOWLEVEL \