aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2011-01-03 18:16:05 +0000
committerImre Kaloz <kaloz@openwrt.org>2011-01-03 18:16:05 +0000
commite99f8f2dd0ca5ed87c91aeb17f70e33d30a183d5 (patch)
tree6b60d6c837a14a9d500a047bb0b4f8b593368ccc /package
parent08448f7e3dfa7d0cff65579bc5174862d7b9edf2 (diff)
downloadupstream-e99f8f2dd0ca5ed87c91aeb17f70e33d30a183d5.tar.gz
upstream-e99f8f2dd0ca5ed87c91aeb17f70e33d30a183d5.tar.bz2
upstream-e99f8f2dd0ca5ed87c91aeb17f70e33d30a183d5.zip
tune ath dependencies - carl9170 can be used on targets with usb but without pci
SVN-Revision: 24893
Diffstat (limited to 'package')
-rw-r--r--package/mac80211/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/mac80211/Makefile b/package/mac80211/Makefile
index 69fe1c16e0..a87178cbb1 100644
--- a/package/mac80211/Makefile
+++ b/package/mac80211/Makefile
@@ -401,7 +401,7 @@ endef
define KernelPackage/ath
$(call KernelPackage/mac80211/Default)
TITLE:=Atheros common driver part
- DEPENDS+= @PCI_SUPPORT +kmod-mac80211
+ DEPENDS+= @PCI_SUPPORT||@USB_SUPPORT +kmod-mac80211
FILES:=$(PKG_BUILD_DIR)/drivers/net/wireless/ath/ath.ko
AUTOLOAD:=$(call AutoLoad,26,ath)
MENU:=1
@@ -415,7 +415,7 @@ define KernelPackage/ath5k
$(call KernelPackage/mac80211/Default)
TITLE:=Atheros 5xxx wireless cards support
URL:=http://linuxwireless.org/en/users/Drivers/ath5k
- DEPENDS+= +kmod-ath
+ DEPENDS+= @PCI_SUPPORT||@TARGET_atheros +kmod-ath
FILES:=$(PKG_BUILD_DIR)/drivers/net/wireless/ath/ath5k/ath5k.ko
AUTOLOAD:=$(call AutoLoad,27,ath5k)
endef
@@ -429,7 +429,7 @@ define KernelPackage/ath9k
$(call KernelPackage/mac80211/Default)
TITLE:=Atheros 802.11n wireless cards support
URL:=http://linuxwireless.org/en/users/Drivers/ath9k
- DEPENDS+= +kmod-ath
+ DEPENDS+= @PCI_SUPPORT +kmod-ath
FILES:= \
$(PKG_BUILD_DIR)/drivers/net/wireless/ath/ath9k/ath9k_common.ko \
$(PKG_BUILD_DIR)/drivers/net/wireless/ath/ath9k/ath9k_hw.ko \