aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2010-12-29 18:08:24 +0000
committerGabor Juhos <juhosg@openwrt.org>2010-12-29 18:08:24 +0000
commit5413cea8baba220dc4b3553261e3cf55a9f3a9dd (patch)
tree60246062943bf696ec81c695446bd21a2fe7b5c6 /package
parent06c41ce02e1c6435b1074e89d9a3fc0d459838af (diff)
downloadupstream-5413cea8baba220dc4b3553261e3cf55a9f3a9dd.tar.gz
upstream-5413cea8baba220dc4b3553261e3cf55a9f3a9dd.tar.bz2
upstream-5413cea8baba220dc4b3553261e3cf55a9f3a9dd.zip
package/kernel: enable CONFIG_INPUT_KEYBOARD for gpio-keys
SVN-Revision: 24853
Diffstat (limited to 'package')
-rw-r--r--package/kernel/modules/other.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index 553466d7bf..cd3e257a89 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -335,7 +335,9 @@ define KernelPackage/input-gpio-keys
SUBMENU:=$(OTHER_MENU)
TITLE:=GPIO key support
DEPENDS:= @GPIO_SUPPORT
- KCONFIG:=CONFIG_KEYBOARD_GPIO
+ KCONFIG:= \
+ CONFIG_KEYBOARD_GPIO \
+ CONFIG_INPUT_KEYBOARD=y
FILES:=$(LINUX_DIR)/drivers/input/keyboard/gpio_keys.ko
AUTOLOAD:=$(call AutoLoad,60,gpio_keys)
$(call AddDepends/input)