aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2021-05-15 00:00:39 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2021-05-17 19:13:43 +0200
commit003fbfbf94083da5b9419a3d784223e322a82e86 (patch)
tree02292f539bbc05b5e828bea77e6e51a6ee828a79 /package
parentf9b0215e282c8d8a0e6b0f64d450fb0e77132d03 (diff)
downloadupstream-003fbfbf94083da5b9419a3d784223e322a82e86.tar.gz
upstream-003fbfbf94083da5b9419a3d784223e322a82e86.tar.bz2
upstream-003fbfbf94083da5b9419a3d784223e322a82e86.zip
openwrt-keyring: Only copy sign key for 21.02
Instead of adding all public signature keys from the openwrt-keyring repository only add the key which is used to sign the OpenWrt 21.02 feeds. If one of the other keys would be compromised this would not affect users of 21.02 release builds. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'package')
-rw-r--r--package/system/openwrt-keyring/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/package/system/openwrt-keyring/Makefile b/package/system/openwrt-keyring/Makefile
index 6f3aa65622..390144e4be 100644
--- a/package/system/openwrt-keyring/Makefile
+++ b/package/system/openwrt-keyring/Makefile
@@ -3,7 +3,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=openwrt-keyring
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL=$(PROJECT_GIT)/keyring.git
@@ -32,7 +32,8 @@ Build/Compile=
define Package/openwrt-keyring/install
$(INSTALL_DIR) $(1)/etc/opkg/keys/
- $(INSTALL_DATA) $(PKG_BUILD_DIR)/usign/* $(1)/etc/opkg/keys/
+ # Public usign key for 21.02 release builds
+ $(INSTALL_DATA) $(PKG_BUILD_DIR)/usign/2f8b0b98e08306bf $(1)/etc/opkg/keys/
endef
$(eval $(call BuildPackage,openwrt-keyring))