aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-03-02 11:17:25 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-03-02 11:17:25 +0000
commite2a5d987bdcbc0bc7c084a03891ebdee0c49bb52 (patch)
treec04f55f71187039b58961f33b938dfe8009611da /package
parent8e0af8361d2debf4e20b669edf9b4cb5b05e2168 (diff)
downloadupstream-e2a5d987bdcbc0bc7c084a03891ebdee0c49bb52.tar.gz
upstream-e2a5d987bdcbc0bc7c084a03891ebdee0c49bb52.tar.bz2
upstream-e2a5d987bdcbc0bc7c084a03891ebdee0c49bb52.zip
package/kernel: package NAND support
SVN-Revision: 30773
Diffstat (limited to 'package')
-rw-r--r--package/kernel/modules/other.mk22
1 files changed, 21 insertions, 1 deletions
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index 9ab6700b7f..5a4cce8ce3 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -629,7 +629,7 @@ define KernelPackage/cs5535-mfd
KCONFIG:=CONFIG_MFD_CS5535
FILES:= \
$(LINUX_DIR)/drivers/mfd/mfd-core.ko \
- $(LINUX_DIR)/drivers/mfd/cs5535-mfd.ko
+ $(LINUX_DIR)/drivers/mfd/cs5535-mfd.ko
AUTOLOAD:=$(call AutoLoad,44,mfd-core cs5535-mfd)
endef
@@ -818,3 +818,23 @@ define KernelPackage/mtdtests/description
endef
$(eval $(call KernelPackage,mtdtests))
+
+
+define KernelPackage/nand
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=NAND flash support
+ KCONFIG:=CONFIG_MTD_NAND \
+ CONFIG_MTD_NAND_IDS \
+ CONFIG_MTD_NAND_ECC
+ FILES:= \
+ $(LINUX_DIR)/drivers/mtd/nand/nand_ids.ko \
+ $(LINUX_DIR)/drivers/mtd/nand/nand_ecc.ko \
+ $(LINUX_DIR)/drivers/mtd/nand/nand.ko
+ AUTOLOAD:=$(call AutoLoad,20,nand_ids nand_ecc nand)
+endef
+
+define KernelPackage/nand/description
+ Kernel module for NAND support.
+endef
+
+$(eval $(call KernelPackage,nand))