aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorEike Ritter <git@rittere.co.uk>2021-03-14 18:50:21 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2021-03-29 22:26:27 +0200
commitb89accdfbc771e9936abf33dd5cfcd6882841564 (patch)
treeb982207eb7bb5c63feff94e6cf783050f65bc0c4 /package
parent290b28664d2522654dd304c40122beeb85f565a6 (diff)
downloadupstream-b89accdfbc771e9936abf33dd5cfcd6882841564.tar.gz
upstream-b89accdfbc771e9936abf33dd5cfcd6882841564.tar.bz2
upstream-b89accdfbc771e9936abf33dd5cfcd6882841564.zip
ppp: compile fix: unset FILTER variable in Makefile
If the environment variable FILTER is set before compilation, compilation of the ppp-package will fail with the error message Package ppp is missing dependencies for the following libraries: libpcap.so.1 The reason is that the OpenWrt-patch for the Makefile only comments out the line FILTER=y. Hence the pcap-library will be dynamically linked if the environment variable FILTER is set elsewhere, which causes compilation to fail. The fix consists on explicitly unsetting the variable FILTER instead. Signed-off-by: Eike Ritter <git@rittere.co.uk> (cherry picked from commit 46cd0765d0c585dc0b48c8c0a3f116ef83cd580f)
Diffstat (limited to 'package')
-rw-r--r--package/network/services/ppp/patches/610-pppd_compile_fix.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/package/network/services/ppp/patches/610-pppd_compile_fix.patch b/package/network/services/ppp/patches/610-pppd_compile_fix.patch
new file mode 100644
index 0000000000..474f11832a
--- /dev/null
+++ b/package/network/services/ppp/patches/610-pppd_compile_fix.patch
@@ -0,0 +1,12 @@
+--- a/pppd/Makefile.linux
++++ b/pppd/Makefile.linux
+@@ -48,7 +48,8 @@ MPPE=y
+ # Uncomment the next line to include support for PPP packet filtering.
+ # This requires that the libpcap library and headers be installed
+ # and that the kernel driver support PPP packet filtering.
+-#FILTER=y
++# libpcap statically linked in OpenWRT, hence disabled here.
++FILTER=
+
+ # Support for precompiled filters
+ PRECOMPILED_FILTER=y