aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-06-02 12:44:16 +0000
committerJohn Crispin <john@openwrt.org>2014-06-02 12:44:16 +0000
commit85b8897d1a20b774ffeb7432e7efeb2ec97049e6 (patch)
treee78d72bb936cfa0a8bf5b2385d73783236904935 /package
parent3936ed402896c4e35ba9a84cc31f92feecb0a139 (diff)
downloadupstream-85b8897d1a20b774ffeb7432e7efeb2ec97049e6.tar.gz
upstream-85b8897d1a20b774ffeb7432e7efeb2ec97049e6.tar.bz2
upstream-85b8897d1a20b774ffeb7432e7efeb2ec97049e6.zip
fstools: stage libubi-utils static library and headers
Use InstallDev to make libubi-utils available for linking in uboot-envtools. Signed-off-by: Daniel Golle <daniel@makrotopia.org> SVN-Revision: 40928
Diffstat (limited to 'package')
-rw-r--r--package/system/fstools/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/package/system/fstools/Makefile b/package/system/fstools/Makefile
index 40adf0af57..b10f105a74 100644
--- a/package/system/fstools/Makefile
+++ b/package/system/fstools/Makefile
@@ -78,6 +78,13 @@ define Package/block-mount/install
endef
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/include
+ $(CP) $(PKG_INSTALL_DIR)/usr/include/*.h $(1)/usr/include/
+ $(INSTALL_DIR) $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libubi-utils.a $(1)/usr/lib/
+endef
+
$(eval $(call BuildPackage,fstools))
$(eval $(call BuildPackage,ubi-flash))
$(eval $(call BuildPackage,block-mount))
ef='#n158'>158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183 184 185 186 187 188 189 190 191 192 193 194 195 196 197 198 199 200 201 202 203 204 205 206 207 208 209 210 211 212 213 214 215 216 217 218 219 220 221 222 223 224 225 226 227 228 229 230 231 232 233 234 235 236 237 238 239 240 241 242 243 244 245 246 247 248 249 250 251 252 253 254 255 256 257 258 259 260 261 262 263 264 265 266 267 268 269 270 271 272 273 274 275 276 277 278 279 280 281 282 283