aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-03-02 11:17:27 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-03-02 11:17:27 +0000
commit370f9b6793ca1486381171d25d35b0980380769f (patch)
treeb11a3bf1794b61dc8e9c7fca8aaf9d2f30b59c23 /package
parente2a5d987bdcbc0bc7c084a03891ebdee0c49bb52 (diff)
downloadupstream-370f9b6793ca1486381171d25d35b0980380769f.tar.gz
upstream-370f9b6793ca1486381171d25d35b0980380769f.tar.bz2
upstream-370f9b6793ca1486381171d25d35b0980380769f.zip
package/kernel: package nandsim module
SVN-Revision: 30774
Diffstat (limited to 'package')
-rw-r--r--package/kernel/modules/other.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index 5a4cce8ce3..612603ba47 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -838,3 +838,19 @@ define KernelPackage/nand/description
endef
$(eval $(call KernelPackage,nand))
+
+
+define KernelPackage/nandsim
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=NAND simulator
+ DEPENDS:=+kmod-nand
+ KCONFIG:=CONFIG_MTD_NAND_NANDSIM
+ FILES:=$(LINUX_DIR)/drivers/mtd/nand/nandsim.ko
+endef
+
+define KernelPackage/nandsim/description
+ Kernel module for NAND flash simulation.
+endef
+
+$(eval $(call KernelPackage,nandsim))
+