aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorYe Tao <tydus@hongo.wide.ad.jp>2017-02-19 21:57:11 +0900
committerFelix Fietkau <nbd@nbd.name>2017-04-03 08:48:12 +0200
commit7a5257654c552e2ceeaaafacdff6062f27bd601e (patch)
tree6f62acb7a29c32982bd0b0d85295e7054df222ed /package
parentc3778f2647aac67f019b38eb157c224b675d532f (diff)
downloadupstream-7a5257654c552e2ceeaaafacdff6062f27bd601e.tar.gz
upstream-7a5257654c552e2ceeaaafacdff6062f27bd601e.tar.bz2
upstream-7a5257654c552e2ceeaaafacdff6062f27bd601e.zip
modules: Add kmod-igbvf kernel module for Intel(R) 82576 Virtual Function Ethernet adapters
Intel(R) 82576 is an adapter which supports SR-IOV. Thus the host can assign Virtual Functions (VFs) to different VMs by the PCI-E Passthrough (e.g. VFIO for KVM), to gain different advantages (performance, VF to VF communications, host kernel offload, etc.). The driver of the passthroughed VFs is the igbvf (igb is NOT compatible). This is essential for VM guests, to enable them to utilize this feature. Signed-off-by: Ye Tao <tydus@hongo.wide.ad.jp>
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/netdevices.mk18
1 files changed, 18 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/netdevices.mk b/package/kernel/linux/modules/netdevices.mk
index 9d861d6bda..4af06c610d 100644
--- a/package/kernel/linux/modules/netdevices.mk
+++ b/package/kernel/linux/modules/netdevices.mk
@@ -522,6 +522,24 @@ endef
$(eval $(call KernelPackage,igb))
+define KernelPackage/igbvf
+ SUBMENU:=$(NETWORK_DEVICES_MENU)
+ TITLE:=Intel(R) 82576 Virtual Function Ethernet support
+ DEPENDS:=@PCI_SUPPORT @TARGET_x86 +kmod-i2c-core +kmod-i2c-algo-bit +kmod-ptp
+ KCONFIG:=CONFIG_IGBVF \
+ CONFIG_IGB_HWMON=n \
+ CONFIG_IGB_DCA=n
+ FILES:=$(LINUX_DIR)/drivers/net/ethernet/intel/igbvf/igbvf.ko
+ AUTOLOAD:=$(call AutoLoad,35,igbvf)
+endef
+
+define KernelPackage/igbvf/description
+ Kernel modules for Intel(R) 82576 Virtual Function Ethernet adapters.
+endef
+
+$(eval $(call KernelPackage,igbvf))
+
+
define KernelPackage/ixgbe
SUBMENU:=$(NETWORK_DEVICES_MENU)
TITLE:=Intel(R) 82598/82599 PCI-Express 10 Gigabit Ethernet support