aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2008-11-15 17:39:50 +0000
committerFlorian Fainelli <florian@openwrt.org>2008-11-15 17:39:50 +0000
commitac679ab30285b6ad7618efcb72665b7d74695b58 (patch)
tree8d2486e1f07037278fd90269c8376f7c13439407 /package
parent985166f637a80003b1640f9912d09539f3c50c6d (diff)
downloadupstream-ac679ab30285b6ad7618efcb72665b7d74695b58.tar.gz
upstream-ac679ab30285b6ad7618efcb72665b7d74695b58.tar.bz2
upstream-ac679ab30285b6ad7618efcb72665b7d74695b58.zip
The package kmod-net-prism54 misses the firmware file in /lib/firmware.
Signed-Off-By: Joerg Albert <jal2 at gmx.de> SVN-Revision: 13223
Diffstat (limited to 'package')
-rw-r--r--package/kernel/modules/wireless.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/package/kernel/modules/wireless.mk b/package/kernel/modules/wireless.mk
index f83bb723c6..4db22aee22 100644
--- a/package/kernel/modules/wireless.mk
+++ b/package/kernel/modules/wireless.mk
@@ -196,5 +196,22 @@ define KernelPackage/net-prism54/description
Kernel modules for Intersil Prism54 support
endef
+# Prism54 FullMAC firmware (jbnore.free.fr seems to be rather slow, so we use daemonizer.de)
+#PRISM54_FW:=p54pcifm_1.0.4.3.arm
+PRISM54_FW:=1.0.4.3.arm
+
+define Download/net-prism54
+ FILE:=$(PRISM54_FW)
+# URL:=http://jbnote.free.fr/prism54usb/data/firmwares/
+ URL:=http://daemonizer.de/prism54/prism54-fw/fw-fullmac/
+ MD5SUM:=8bd4310971772a486b9784c77f8a6df9
+endef
+
+define KernelPackage/net-prism54/install
+ $(INSTALL_DIR) $(1)/lib/firmware
+ $(INSTALL_DATA) $(DL_DIR)/$(PRISM54_FW) $(1)/lib/firmware/isl3890
+endef
+
+$(eval $(call Download,net-prism54))
$(eval $(call KernelPackage,net-prism54))