aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-11-05 22:29:14 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-11-05 22:29:14 +0000
commita006cb5e5cf53c4dec223bc56a40773ee4bc2591 (patch)
tree1954a4524ada2dfb0d9ca0ba585d51473dbba51a /package
parentf70c8b37e4efff5127f489da3f160fa3585848b1 (diff)
downloadupstream-a006cb5e5cf53c4dec223bc56a40773ee4bc2591.tar.gz
upstream-a006cb5e5cf53c4dec223bc56a40773ee4bc2591.tar.bz2
upstream-a006cb5e5cf53c4dec223bc56a40773ee4bc2591.zip
iproute2: compile the static libraries with $(FPIC), as they are reused by other packages for inclusion into shared libraries should fix collectd build failures on mips
SVN-Revision: 18323
Diffstat (limited to 'package')
-rw-r--r--package/iproute2/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/package/iproute2/Makefile b/package/iproute2/Makefile
index b36b95bc9b..a3b5f471cf 100644
--- a/package/iproute2/Makefile
+++ b/package/iproute2/Makefile
@@ -51,9 +51,15 @@ define Build/Configure
$(SED) "s, misc,," $(PKG_BUILD_DIR)/Makefile
endef
+MAKE_FLAGS += \
+ EXTRA_CCOPTS="$(TARGET_CFLAGS)" \
+ KERNEL_INCLUDE="$(LINUX_DIR)/include" \
+ FPIC="$(FPIC)" \
+ all tc/tc ip/ip
+
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR)/netem HOSTCC="$(HOSTCC)" EXTRA_CCOPTS="$(TARGET_CFLAGS)" CFLAGS="-D_GNU_SOURCE -O2 -Wstrict-prototypes -Wall -I ../include -DRESOLVE_HOSTNAMES"
- $(MAKE) -C $(PKG_BUILD_DIR) $(TARGET_CONFIGURE_OPTS) EXTRA_CCOPTS="$(TARGET_CFLAGS)" KERNEL_INCLUDE=$(LINUX_DIR)/include all tc/tc ip/ip
+ $(Build/Compile/Default)
endef
define Build/InstallDev