aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2010-08-16 09:12:46 +0000
committerNicolas Thill <nico@openwrt.org>2010-08-16 09:12:46 +0000
commit8386207f1ff4339ab72bafca3c1b415628533e4b (patch)
tree165b96f8694422639206b5cf141c22cf2981a245 /package
parent28d879da88eee809885772a1d789b26a34d75b71 (diff)
downloadupstream-8386207f1ff4339ab72bafca3c1b415628533e4b.tar.gz
upstream-8386207f1ff4339ab72bafca3c1b415628533e4b.tar.bz2
upstream-8386207f1ff4339ab72bafca3c1b415628533e4b.zip
package/grub: add a prereq check for 32 bits host development files when building on x86_64 (closes: #7753)
SVN-Revision: 22667
Diffstat (limited to 'package')
-rw-r--r--package/grub/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/package/grub/Makefile b/package/grub/Makefile
index 5fd2a23088..426b9c3673 100644
--- a/package/grub/Makefile
+++ b/package/grub/Makefile
@@ -88,5 +88,16 @@ define Package/grub/install
$(CP) $(PKG_INSTALL_DIR)/usr/sbin/* $(1)/usr/sbin/
endef
+ifeq ($(HOST_ARCH),x86_64)
+ define Require/working-gcc-m32
+ echo 'int main(int argc, char **argv) { return 0; }' | \
+ gcc -x c -o $(TMP_DIR)/a.out - -m32 -lc
+ endef
+endif
+
+$(eval $(call Require,working-gcc-m32, \
+ Please install 32 bits development files. (gcc-multilib on Debian/Ubuntu, gcc.i686 and libgcc.i686 on CentOS/Fedora/RHEL) \
+))
+
$(eval $(call HostBuild))
$(eval $(call BuildPackage,grub))