aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2018-05-27 15:13:48 -0700
committerJo-Philipp Wich <jo@mein.io>2018-12-18 09:11:40 +0100
commit60b29c9c177d7865dd116eeb574fc9c8ab775b77 (patch)
treed9f4afa6f3808a63a34389bf07804db12cc5d427 /package
parent0d3bdf7b59404580f21db2fa59769993274d5105 (diff)
downloadupstream-60b29c9c177d7865dd116eeb574fc9c8ab775b77.tar.gz
upstream-60b29c9c177d7865dd116eeb574fc9c8ab775b77.tar.bz2
upstream-60b29c9c177d7865dd116eeb574fc9c8ab775b77.zip
curl: Add ca-bundle dependency
While building, curl complains that the path specified is missing. Also, without ca-bundle, something like 'curl https://www.google.com' does not work due to a certificate verify error. Signed-off-by: Rosen Penev <rosenp@gmail.com> (backported from 7a20c7a05d52f9bb3c82742098457bfbed869a8a)
Diffstat (limited to 'package')
-rw-r--r--package/network/utils/curl/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/network/utils/curl/Makefile b/package/network/utils/curl/Makefile
index 522460eff7..b4e3fd9d99 100644
--- a/package/network/utils/curl/Makefile
+++ b/package/network/utils/curl/Makefile
@@ -88,7 +88,7 @@ define Package/libcurl
CATEGORY:=Libraries
DEPENDS:= +LIBCURL_WOLFSSL:libwolfssl +LIBCURL_OPENSSL:libopenssl +LIBCURL_GNUTLS:libgnutls +LIBCURL_MBEDTLS:libmbedtls
DEPENDS += +LIBCURL_ZLIB:zlib +LIBCURL_THREADED_RESOLVER:libpthread +LIBCURL_LDAP:libopenldap +LIBCURL_LIBIDN2:libidn2
- DEPENDS += +LIBCURL_SSH2:libssh2 +LIBCURL_NGHTTP2:libnghttp2
+ DEPENDS += +LIBCURL_SSH2:libssh2 +LIBCURL_NGHTTP2:libnghttp2 +ca-bundle
TITLE:=A client-side URL transfer library
MENU:=1
endef