aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorIvan Shapovalov <intelfx@intelfx.name>2018-05-14 00:05:43 +0300
committerJo-Philipp Wich <jo@mein.io>2018-12-18 09:43:57 +0100
commitfc0907bc25991a526ce4da001217d6a64045ffda (patch)
treefe23b29f8560b8fc48f3fa1ec312eaa5b1e816c4 /package
parentb7beb89b5838079e0985a7a50147424666214cf9 (diff)
downloadupstream-fc0907bc25991a526ce4da001217d6a64045ffda.tar.gz
upstream-fc0907bc25991a526ce4da001217d6a64045ffda.tar.bz2
upstream-fc0907bc25991a526ce4da001217d6a64045ffda.zip
netifd: drop conflicting 'device' interface property
Do not set device runtime property on interfaces in the hotplug handler and in fixup_interfaces(). This property conflicts with device option in several proto handlers (mainly QMI and other WWAN/3G protos) and does not seem to be used anywhere. Signed-off-by: Ivan Shapovalov <intelfx@intelfx.name> Signed-off-by: Hans Dedecker <dedeckeh@gmail.com> [PKG_RELEASE increase] (backported from 91b5b2e20d531584918c62a6c6cd046f0580f50a)
Diffstat (limited to 'package')
-rw-r--r--package/network/config/netifd/Makefile2
-rw-r--r--package/network/config/netifd/files/etc/hotplug.d/iface/00-netstate1
-rwxr-xr-xpackage/network/config/netifd/files/lib/network/config.sh3
3 files changed, 1 insertions, 5 deletions
diff --git a/package/network/config/netifd/Makefile b/package/network/config/netifd/Makefile
index d77fe9b96e..f8ad3a8d99 100644
--- a/package/network/config/netifd/Makefile
+++ b/package/network/config/netifd/Makefile
@@ -1,7 +1,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=netifd
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL=$(PROJECT_GIT)/project/netifd.git
diff --git a/package/network/config/netifd/files/etc/hotplug.d/iface/00-netstate b/package/network/config/netifd/files/etc/hotplug.d/iface/00-netstate
index 023025cd1a..71ccb01915 100644
--- a/package/network/config/netifd/files/etc/hotplug.d/iface/00-netstate
+++ b/package/network/config/netifd/files/etc/hotplug.d/iface/00-netstate
@@ -1,7 +1,6 @@
[ ifup = "$ACTION" ] && {
uci_toggle_state network "$INTERFACE" up 1
[ -n "$DEVICE" ] && {
- uci_toggle_state network "$INTERFACE" device "$(uci -q get network.$INTERFACE.ifname)"
uci_toggle_state network "$INTERFACE" ifname "$DEVICE"
}
}
diff --git a/package/network/config/netifd/files/lib/network/config.sh b/package/network/config/netifd/files/lib/network/config.sh
index 9128971dab..0ded45edc4 100755
--- a/package/network/config/netifd/files/lib/network/config.sh
+++ b/package/network/config/netifd/files/lib/network/config.sh
@@ -41,15 +41,12 @@ fixup_interface() {
config_get type "$config" type
config_get ifname "$config" ifname
- config_get device "$config" device "$ifname"
[ "bridge" = "$type" ] && ifname="br-$config"
- config_set "$config" device "$ifname"
ubus_call "network.interface.$config" status || return 0
json_get_var l3dev l3_device
[ -n "$l3dev" ] && ifname="$l3dev"
json_init
config_set "$config" ifname "$ifname"
- config_set "$config" device "$device"
}
scan_interfaces() {